Forum Visual Studio

Can't run Android x86 emulator in VS2017

FactoryOptimizrFactoryOptimizr USUniversity ✭✭

After I installed VS2017, I fired up the new Android ARM phone emulator, but as it launched (V-E-R-Y slow!!!), the following charming dialog appeared:

Yikes! So I launched the Android x86 phone emulator, but it failed to launch, generating this error:

So I ran the bcdedit command recommended in the error message, and the x86 emulator started up just fine. (MUCH faster.)

Unfortunately, the Windows Phone emulator would no longer run, generating this hypervisor error,

But the hypervisor was running just fine, by all indications, and my computer -- a Surface Book -- has hardware assisted virtualization enabled by default (there's no BIOS setting for this).

So...I rebuilt the laptop, reinstalling Windows 10 and Visual Studio. I verified all the Android components were up to date and, after some internet research, ran Intel's intelhaxm-android.exe HAXM installer, but that did not correct the problem. So I ran the bcdedit command again, and, again, the x86 emulator fired up just as nice as you please, but, again, the Windows phone emulator wouldn't run. more time...I rebuilt the laptop and reloaded Windows 10 and Visual Studio......and now I'm back where I started. Still can't run the Android x86 emulator and the ARM emulator is slower than anything.

Anyone got any recommendations?


  • DirkWilhelmDirkWilhelm USMember ✭✭✭✭

    With the bcedit command you disabled Hyper-V so it is no wonder that the windows phone emulater is not running anymore.

    You can enable the hypervisor again by the same bcdedit command, just replace the 'off' with 'on'.

    As an alternative use the Visual Studio Emulator for Android. You can install it using tjhe VS2017 Installer (take a look at the extra components). This emulator also needs Hyper-V enabled, just like the Windows Phone emulator.

  • FactoryOptimizrFactoryOptimizr USUniversity ✭✭

    Thanks for that info, @DirkWilhelm. Interesting that Microsoft's own emulator isn't part of the standard VS2017 install. Should I be concerned that this emulator is for what seems to be a pretty old version of Android? (I'm pretty new to mobile development...)

  • FactoryOptimizrFactoryOptimizr USUniversity ✭✭

    Well...a good attempt, anyhow. While the VS emulator for Android runs, even the most simple "Hello, world" app immediately exits with the following error.

    InspectorDebugSession(3): Constructed
    Android application is debugging.
    Could not connect to the debugger.
    05-06 12:19:31.963 D/dalvikvm( 1286): Late-enabling CheckJNI
Sign In or Register to comment.