Xamarin.Mac not visible in Xamarin Studio even after manual installation

Hello

I'm using Xamarin Studio Community 6.3 on my Mac (OSX 10.11.6) and I can not see any reference to Xamarin.Mac or Cocoa forms when creating a new solution (see screenshot)

I tried reinstalling Xamarin Studio, and I also installed Xamarin.Mac manually (following instructions in the FAQ on this forum) but it's made no difference.

I originally installed Xamarin from the MonoDevelop site so it's possible my installations have wound up in the wrong folder or something similar, but I haven't the faintest idea where I'd look to fix this if this is the case. Any help would be appreciated. Thanks!

Best Answer

Answers

  • BytesGuyBytesGuy GBXamarin Team Xamurai

    As a first pass, try doing a full uninstall to make sure you are starting afresh:

    https://developer.xamarin.com/guides/cross-platform/getting_started/installation/uninstalling_xamarin

    After that try installing Xamarin again. Hopefully this will work for you.

  • GeorgiaBlairGeorgiaBlair AUMember

    Thanks for the response. I fully uninstalled Xamarin and reinstalled it, but still can't see any Xamarin.Mac templates. Tried installing Xamarin.Mac manually again, too.

  • GeorgiaBlairGeorgiaBlair AUMember

    Aha, there was no SDK appearing, so I reinstalled Xcode and now Xamarin.Mac is showing up correctly. Thank you!

Sign In or Register to comment.