Visual Studio for Mac Preview 8 won't build

kizanlikkizanlik ✭✭TRMember ✭✭

Hi,

After updating from Visual Studio for Mac Preview 7 to Visual Studio for Mac Preview 8, I am not able to run any project. "Building: ..." message appears but building stops at arbitrary positions (sometimes at 30%, sometimes at 70%). There is not any warning / error message.

How can I fix this?

Answers

  • HugoLogmans_HugoLogmans_ ✭✭✭ NLMember ✭✭✭
    edited April 2017

    Same here, cannot build anything anymore, a new project compiles just once and after adding some code never again...
    I also cannot cancel the build, need to force-quit VS.

  • ToddHenderson.0820ToddHenderson.0820 USMember

    Same here, is there any update on this?

  • MatthewEdelbrockMatthewEdelbrock USMember
    edited April 2017

    Same here. I saw that the IDE updated and now all of my projects won't build. I can clean the projects once before a build but cleaning after cancelling a build, the cleaning hangs up just like the build.

    Update:
    Its the XamlCTask in /packages/Xamarin.Forms.2.3.4.231/build/portable-win+net45+wp80+win81+wpa81+MonoAndroid10+Xamarin.iOS10+xamarinmac20

  • AustinEmser.6834AustinEmser.6834 USMember

    Same here.

  • MatthewEdelbrockMatthewEdelbrock USMember

    I don't know if it was a coincidence but I was able to install Xamarin Studio, build the project, got the XamlCTask error, removed it from the project file, built it again getting the XamlCTask missing error, put it back and the build started working.

  • renzskarenzska ✭✭ USMember ✭✭
    edited April 2017

    Same issue here. Hit build and nothing appears in the build log. The ide build message shows in the top bar indefinitely, but nothing happens. Same goes for cleaning as well.

  • HernandoZHernandoZ ✭✭ GBUniversity ✭✭

    yep same here ....how do we fix this ?? i cannot build any projects

  • kizanlikkizanlik ✭✭ TRMember ✭✭

    Hi,

    I have found these:

    • If something wrong with a XAML file, builder hangs. No warning, no error. Just waits.
    • If something wrong with a CS file, IDE lists the errors.
    • If your solution has Xamarin.Forms Class Library projects and one of them doesn't have a source code file in the root folder, VSfM-P8 doesn't compile the project and builder hangs. If you create a dummy XAML page in the root, the Xamarin.Forms Class Library project is built.
  • AssemHAssemH CAMember
    edited April 2017

    Hi,

    Same issue. Simple projects with no references seem to build ok if built individually. But a Forms project the references others hangs. Can be cancelled the first time, but trying to build (and hang) then cancel again just stays stuck in build.

    Does anyone have any workarounds?

    EDIT:

    The only workaround i found is to open VS settings/.NET Runtimes and select Mono 4.8.0 as default. Builds as expected.

  • lukeelukee USMember

    the workaround of setting the .NET Runtime to Mono 4.8 (instead of Mono 5.0) worked for me too

  • MichaelThwaiteMichaelThwaite ✭✭ USMember ✭✭

    Switching back to 4.8.1 also resolves not being able to set breakpoints in older code even though the build appears to complete without error.

  • kizanlikkizanlik ✭✭ TRMember ✭✭

    Hi,

    Thank you for your helpful workaround suggestion. It helped me but I faced some other issues which are not reproducible. So I decided to continue on Xamarin Studio / stable channel for a while. Thank you.

  • DavidDancyDavidDancy ✭✭✭✭ AUMember ✭✭✭✭

    I've had this problem too. My only recourse was to force-quit VS Mac. Sometimes I had to also delete the build stuff in /obj and /bin as well.

  • DavidDancyDavidDancy ✭✭✭✭ AUMember ✭✭✭✭

    In fact I'd call this preview 8 (I'm on 7.0 build 2845, Mono 5.0) "barely usable". It hangs a lot and restarting it doesn't fix the hang.

    I've had the IDE hang after:

    • Refactoring (renaming) some classes (which BTW also caused other problems)
    • Changing network configuration on my laptop from LAN to WiFi and back
    • Adding or updating packages
    • Cancelling an in-progress build

    I realise this is an Alpha version but even so this version has really let the quality bar slide.

  • DavidDancyDavidDancy ✭✭✭✭ AUMember ✭✭✭✭

    I just updated to build 2943 and I'm pleased to report that the build issue appears to be fixed. Seems to have been related to a problem (now fixed) that was triggered whenever a project needed reloading for any reason.

Sign In or Register to comment.