Forum Visual Studio

Debugging with VirtualBox-based emulator on Visual studio

kenneth.leekenneth.lee USMember ✭✭✭

Hi guys,

I have been struggling with using my ARM emulator to debug as it is horrendously slow and I'm having problem building on a x86 emulator.
I have found a emulator called MeMU which is a VirtualBox-based emulator and I got adb to detect this device. However Visual studios will not show this in my Target Device for debugging. I can see all my other ARM and x86 emulators but not MeMU.

Any help on this issue would be hugely appreciated.

Note: Yes i got my startup project set.

Best Answer


  • SirAndriySirAndriy USMember ✭✭✭

    I guest you need android emulator, if yes then:
    1. Try to use emeator for VS
    2. For best performance of AVD emulators (ARM emulator) you need to disable Hyper-V
    3. You can use emulator from Xamarin

    p.s. About why you can't see some of other emulator - check min version of android in your project (project->properties->Android Application->Minimum Android version) and version android in emulator that you can't see in list

  • kenneth.leekenneth.lee USMember ✭✭✭

    @SirAndriy Thanks for your suggestions. I have already tried both Hyper-V disable and enable but haven't seen a noticeable improvement. I have yet to try mstf-android-emulator and xamarin android player so hopefully that gives me much better performance.

Sign In or Register to comment.