Forum Libraries, Components, and Plugins
We are excited to announce that the Xamarin Forums are moving to the new Microsoft Q&A experience. Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

We encourage you to head over to Microsoft Q&A for .NET for posting new questions and get involved today.

Urhosharp.Forms app exits unexpectedly on iOS

Hi there,
I'm using Urhosharp with Xamarin.Forms to show a simple mdl file. Everything works fine on both android and ios simulator. And also works on android devices. But the problem is, the same app is not working on iOS devices. It exits in a minute or two. Firstly it seems that everything works fine, but then it closes the whole app without any error messages.
While it creates a diagnostic file in the privacy section of iOS, it says that:

Exception Subtype: KERN_PROTECTION_FAILURE at 0x01a145e0
Triggered by Thread: 0

The same error and that exiting unexpectedly thing shows up on the FormsSample app which is the chart example that works with Xamarin.Forms and Urhosharp. The sample also generates a similar diagnostic file.

I've removed all of the thing happening in Update event, and all other interaction stuff such as OnTouched. And just opened the app on a iOS device and wait for it. And some after while it exits and creates that diagnostic file again.

I have to solve this problem, but nothing that I've tried overcame this error.

Any help would be greatly appreciated...


  • EgorBoEgorBo BYXamarin Team ✭✭✭

    @OylesineMosnos the next nuget update for UrhoSharp will contain a bunch of fixes for iOS crashes.

  • OylesineMosnosOylesineMosnos USMember

    Thanks for the information @EgorBo . Is there a scheduled update for UrhoSharp? If there is, when will it be?

  • DaspuruDaspuru USMember ✭✭
    edited March 2017

    Hello, any news with this issue ?

    The point here is that we can say Urho just don´t work in Xamarin.Forms. iOS crashes even in the official Xamarin sample?

    I hope the Xamarin team can help to fix it soon or give us hints to fix this issue.


Sign In or Register to comment.