Forum Visual Studio

App crasht after start in VS Emulator

RafaGRafaG USMember ✭✭

Hi guys!

I am not being able to run any app, either a blank one, in the VS Emulator on a PC with AMD Processor (Phenom II X4 955).
I tried with Xamarin Forms, Xamarin Native, Android blank App & Singleview app and all crash after start. (I an not able to reach any debugpoint)

VS Emulator starts well and it also works nice and smooth, but when I trie to deploy an app, it crashes after it starts.
It doesnt matter if I do debug or release, it crashes always. I also tried:

  • Unchecking Shared Runtime
  • Unchecking Fast Deployment
  • Checking all android images
  • Checking "Migrate to....." in Hyper V
  • Uninstall & install Xamarin and VS Emulator
  • Deleting all Emulators, deleting Switches in HyperV

But nothing....
I get always in logcat an issue with miscorlib or libmono not being found...

Another issue I have is that Im not being able to create a API 23 freezes on Loading OS...
Emulators with API 22,21,20,19 worked all OK....

I am already 3 days trying to fix this....and as I have tried ABSOLUTE all what I have found...nothing has fixed the issue...I am starting to think it is a problem tih my "old" AMD processor.

BUT if I install any .apk (for example GMail) in the Emulator it works as it should.....

I hope anyone here can help me because I am really struggling here...OMG

Thanks in advance :)


  • prashantvcprashantvc USXamarin Team Xamurai

    @RafaG Could you post logs from logcat when crash happens? It will help us to troubleshoot the issue.
    Also, I recommend using Google x86 emulators they are fast and more reliable than VS emulators at the moment

  • ClintStLaurentClintStLaurent USUniversity ✭✭✭✭✭

    Does your app crash on a physical device?

    Its not a real issue until it happens on a physical device

    If you make a new "Welcome to Xamarin" solution, clean build and deploy to your emulator - does that run?

Sign In or Register to comment.