Forum Visual Studio

Xamarin Forms Intellisense Visual Studio (2015 AND 2017) missing ??

For Visual Studio 2015, You can enable a "partial" intellisense by opening the Xaml page with the Source Code (Text) Editor.
It's not perfect, but most are Working.

Now I've installed Visual Studio 2017, and I'm totally unable to activate this (important) feature.
I've tried different editors, but without any luck (that is intellisense)!

Do I have to install a special component, or are the feature missing from Xamarin?


  • JohnMillerJohnMiller USForum Administrator, Xamarin Team Xamurai


    It appears to be working for me in both VS 2015 and 2017. I don't see any existing bug reports for an issue in Visual Studio. Do you have any errors in your logs? (Help -> Xamarin -> Open Logs) Check the IDE log files after you experience an issue.

  • ClausHoiteClausHoite USMember

    Actually I'm quite mystified - Yesterday there were NO intellisense - Today its there...

  • VS 2017 RTM user here. Actually, it comes and it goes. Sometimes you just need to restart the IDE. Other times you have to sleep on it and try again the next day :/ . Generally speaking, Xamarin Forms and VS 2017 integration is really disappointing so far. You really have to do better than that! Please don't let Microsoft ruin your wonderful platform!

  • ClausHoiteClausHoite USMember

    OKAY - We try again.
    Create a brand new project, Build the project and started the Xaml editor for the MainPage.Xaml.
    --> NO Intellisense
    Tried some of the other editors, with the same result.

    Finally I restarted Visual Studio (2017), and then: Intellisense are back.
    It seems there are some problems with NEW projects!

  • DomiLoDomiLo CAMember

    Same here, new project - no intellisense. So far no amount VS restarts has fixed it

  • DanishShamimDanishShamim USMember

    Same here - just starting with VS2017 - intellisense is completely missing form xaml cross platform project

  • PierceBogganPierceBoggan USForum Administrator, Xamarin Team, Developer Group Leader Xamurai

    Please see my answer here. It should help you to work around the issue temporarily and provides some more information about the issue. :smile:

Sign In or Register to comment.