I got "Could not find 7zip.exe in xamarin installation" error

JohnyKamnangJohnyKamnang ✭✭BEMember ✭✭

Hi all,
Does anyone know what to do? This error only occur in the IOS version of my xamarin.forms project.
Everything was running fine until I installed nuget package for WindowsAzure.MobileServices (Microsoft.Bcl,Microsoft.Bcl.Build,Microsoft.Net.Http)

Even If I remove those packages, I've got this error...

Tagged:
«1

Answers

  • JohnyKamnangJohnyKamnang ✭✭ BEMember ✭✭

    ok, I've found the solution:
    Go to your project.ios properties --> the select the tab "iOS Application"
    Then fill in every fields (version, build,...) but clear the field 'Launch Story"
    I also changed the orientation

    Then it compile and works

  • JohnyKamnangJohnyKamnang ✭✭ BEMember ✭✭

    I re-open this topic...
    For an unknown reason, it reappears.. unable to make it work again...

  • TonSnoeiTonSnoei ✭✭ NLMember ✭✭

    Same problem here. Did you solve it already?

  • TonSnoeiTonSnoei ✭✭ NLMember ✭✭

    Solved the problem by updating all Xamarin software where necessary.
    Note: If your primary development platform is Windows you won't notice that, after an XCode upgrade on the MAC, you need to verify the agreement again. If you don't you get into trouble.

  • JamesAltJamesAlt ✭✭ USUniversity ✭✭

    Just wanted to weigh in since I had this issue this morning as well and it might help someone else in the future (probably myself).

    I tried the methods described above with no success. Updated the Xamarin packages in my app, shut down Visual Studio, opened up the package folder, deleted the Xamarin packages (namely the forms packages, including some old ones still in there) and then cleaned and rebuilt and that got it working.

  • WafflesWaffles ✭✭ USMember ✭✭

    I may not be understanding the cause of this error, but for troubleshooting purposes, have you guys tried uninstalling 7zip and reinstalling in the default folder? I dont know much about the Xam installer, but I assume that it checks a default directory, and if 7zip does not exist, it will fresh install. But maybe you guys have a damaged 7zip.

    Im thinking maybe ye olde Xam is seeing that you have the correct 7zip directory, but its not smart enough to check if the 7zip exe is working, or if its named correctly, etc etc.

    Try finding where Xam is expecting to find 7zip and reinstall to that location

  • AngeliTAngeliT USMember

    I got same issue and upgrade Xamarin.Build.Download to latest version will fixed this issue

  • LaumaniaLaumania ✭✭✭ DKMember ✭✭✭

    I have this problem too. Just installed VS2017 on a fresh Windows 10 64bit.

    Android worked in first try, but iOS comes with this:

    "Could not find 7zip.exe in Xamarin installation Dognrapport.Apps.iOS"

  • ruborubo ✭✭ USMember ✭✭

    I have this problem too with Visual Studio 2017 and Xamarin.Build.Download 0.4.2 (currently the latest). No way to build the project. Downgrading to older versions of Xamarin.Build.Download package didn't help either. Extremely annoyed!

  • BillHolmesBillHolmes Xamurai USXamarin Team Xamurai

    Update to the thread. We are working on a patch for Xamarin Build Download. You can view it here. I am waiting on some reviews and will publish a pre-release package to NuGet ASAP.

  • BillHolmesBillHolmes Xamurai USXamarin Team Xamurai

    I have just pushed a fix in a pre-release version of ​Xamarin Build Download. ​Please update your projects to try this version. I do know of one more issue where the extraction may fail stating that the extraction failed to create the symlink. You can work around this error by running Visual Studio as admin. After you build as admin and the files extract correctly you can restart VS with normal privileges. I am working on a fix for this.

  • ruborubo ✭✭ USMember ✭✭

    @BillHolmes Now I'm getting the following with the latest beta:

    The "User7ZipPath" parameter is not supported by the "XamarinDownloadArchives" task. Verify the parameter exists on the task, and it is a settable public instance property.

    I use this with Xamarin.Google.iOS.Maps. Does that package need a fix too?

  • BillHolmesBillHolmes Xamurai USXamarin Team Xamurai

    @rubo. You are in an odd state. It seems that your csproj file is referencing the correct updated targets file for Xamarin.Build.Download, however the dll being loaded is the old one. User7ZipPath is a property I added to the XamarinDownloadArchives class. Be sure that all projects in your solution that reference Xamarin Build Download are pointing to the latest version. I suggest clearing out your packages folder for you solution and restarting VS to allow the packages directory to be rebuilt and reloaded into memory.

    I do not believe that Xamarin.Google.iOS.Maps technically needs to be updated, only that you need to update the version of Xamarin Build Download to the latest. The current version of Maps will work with this version of Xamarin Build Download.

    However I will admit that we should update Xamarin.Google.iOS.Maps by simply updating the dependency version to Xamarin Build Download. This will ensure that the fixed version of Xamarin Build Download is installed by default when installing Maps. However we do need to release a stable Xamarin Build Download first.

  • ruborubo ✭✭ USMember ✭✭

    @BillHolmes You're right. Usually, Xamarin.Build.Download update requires Visual Studio restart but this time it didn't and I forgot to do it manually. I cleaned the NuGet packages cache everywhere and now it works. Thank you so much!

  • BillHolmesBillHolmes Xamurai USXamarin Team Xamurai

    @JonathanDick I am thinking that we need to consider bumping the assembly version of Xamarin Build Download. Maybe that will avoid the problems that rubo saw. The way we have it coded now you will have to ensure that all projects in your solution reference the same version to XBD because I am guessing that only one copy of the dll with a specific version number can be loaded into MSBuild. That may be best practice, but we may be able to to better. Something to think about.

  • ThomasBurkhartThomasBurkhart ✭✭✭✭ DEMember ✭✭✭✭
  • BillHolmesBillHolmes Xamurai USXamarin Team Xamurai

    I have published a new pre-release of Xamarin Build Download to NuGet.

    This should have no effect on iOS users. However Android users of VS should see an improvement in IDE speed and the incorrect warning messages (not able to find referenced assembly) are fixed.

  • EnricoRossiniEnricoRossini ✭✭✭✭ USMember ✭✭✭✭
    edited March 2017

    Hi @BillHolmes
    I updated Xamarin Build Download but now I have two errors.

    The "User7ZipPath" parameter is not supported by the "XamarinDownloadArchives" task. Verify the parameter exists on the task, and it is a settable public instance property.
    The "XamarinDownloadArchives" task could not be initialized with its input parameters.

    In my project I'm using Google Ads.

  • BillHolmesBillHolmes Xamurai USXamarin Team Xamurai

    @EnricoRossini You need to restart VS when you update Xamarin Build Download. This will load the new tasks dll into memory.

  • EnricoRossiniEnricoRossini ✭✭✭✭ USMember ✭✭✭✭
    edited March 2017

    @BillHolmes Thanks, I did but I still have the same errors.

  • BillHolmesBillHolmes Xamurai USXamarin Team Xamurai

    @EnricoRossini odd. This is the same issue that rubo listed on March 9. See above. I feel that the cause is still the same. You have loaded a targets file that is newer than the tasks dll that is in memory.

    Look in all projects in your solution. You want to be sure that all projects are using the same version of Xamairn Build Download. Then I suggest deleting the packages folder in your solution directory from disk. When you open VS again it will restore all the packages again.

    Let me know what you find and if you are still having problems.

  • EnricoRossiniEnricoRossini ✭✭✭✭ USMember ✭✭✭✭

    @BillHolmes I tried to do evething; iOS project doesn't work

  • BillHolmesBillHolmes Xamurai USXamarin Team Xamurai

    @EnricoRossini I am really stumped here. The property does exist. I checked again in source and I downloaded a new copy from NuGet and disassembled the dll. It is there.

    For now I can only suggest that the nuclear option of rebooting the system to ensure that there are no processes hanging around that is keeping an old cached version in memory.

    If you want, zip up the dll and post it here for me to inspect.

    packages/Xamarin.Build.Download.0.4.3-beta2/build/Xamarin.Build.Download.dll

  • EnricoRossiniEnricoRossini ✭✭✭✭ USMember ✭✭✭✭

    Thanks @BillHolmes
    In attach the zip

  • EnricoRossiniEnricoRossini ✭✭✭✭ USMember ✭✭✭✭

    C:\Project\WordBankEasy\packages\Xamarin.Build.Download.0.4.3-beta2\build\Xamarin.Build.Download.targets(63,3): error : Could not find a part of the path 'C:\Users\EnryPC\AppData\Local\XamarinBuildDownloadCache\GSymblU-1.1.2\Frameworks\frameworks\GoogleSymbolUtilities.framework\GoogleSymbolUtilities'.
    C:\Project\WordBankEasy\packages\Xamarin.Build.Download.0.4.3-beta2\build\Xamarin.Build.Download.targets(63,3): error : at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
    C:\Project\WordBankEasy\packages\Xamarin.Build.Download.0.4.3-beta2\build\Xamarin.Build.Download.targets(63,3): error : at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy, Boolean useLongPath, Boolean checkHost)
    C:\Project\WordBankEasy\packages\Xamarin.Build.Download.0.4.3-beta2\build\Xamarin.Build.Download.targets(63,3): error : at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share)
    C:\Project\WordBankEasy\packages\Xamarin.Build.Download.0.4.3-beta2\build\Xamarin.Build.Download.targets(63,3): error : at Xamarin.Build.Download.XamarinBuildiOSResourceRestore.LoadResource(String resourceFullPath, String assemblyName)
    C:\Project\WordBankEasy\packages\Xamarin.Build.Download.0.4.3-beta2\build\Xamarin.Build.Download.targets(63,3): error : at Xamarin.Build.Download.BaseXamarinBuildResourceRestore.MergeResources(IAssemblyResolver resolver, String originalAsmPath, String mergedAsmPath, String assemblyName, List`1 resourceItems)

  • BillHolmesBillHolmes Xamurai USXamarin Team Xamurai

    @EnricoRossini I inspected the dll you sent and XamarinDownloadArchives does have a public settable property called User7ZipPath.

    Now I see that you have provided a different build log section. That suggests that you have somehow gotten past the XamarinDownloadArchives step.

    What is occurring now is that the build is attempting to access the downloaded resources. Can you check the following path to see if the file exists or not? Look around in that path to see if any of the folders in the path exist.

    C:\Users\EnryPC\AppData\Local\XamarinBuildDownloadCache\GSymblU-1.1.2\Frameworks\frameworks\GoogleSymbolUtilities.framework\GoogleSymbolUtilities

  • EnricoRossiniEnricoRossini ✭✭✭✭ USMember ✭✭✭✭

    Screenshot: found it?

  • BillHolmesBillHolmes Xamurai USXamarin Team Xamurai

    @EnricoRossini,

    So it does not exist exactly where it should. We will have to look into this. ( @IsraelSoto )

    I think you can work around this. It is going to be ugly. Sorry.

    You can create a frameworks folder in C:\Users\EnryPC\AppData\Local\XamarinBuildDownloadCache\GSymblU-1.1.2\Frameworks and move or copy the GoogleSymbolUtilities.framework folder into that. Or you can edit Firebase.Analytics.targets file on the following line and remove the extra frameworks folder from that path.

    Firebase.Analytics.targets line

  • EnricoRossiniEnricoRossini ✭✭✭✭ USMember ✭✭✭✭

    Thanks @BillHolmes This error is fixed!
    I have some more but I can resolve them

  • BillHolmesBillHolmes Xamurai USXamarin Team Xamurai

    @EnricoRossini,

    I checked over everything again and I am not sure how this happened. The tgz file listed in the targets file has a Frameworks/frameworks folder. Not sure how this extracted to this state on your system. I cleared our all of my caches and ran a test build on my Windows system using Firebase Analytics and all downloaded and built just fine.

    Any insight that you can give us to understand the error would be appreciated. Otherwise I am glad to hear that you are on your way to building!

  • philmozphilmoz AUMember
    edited March 2017

    Xamarin.Build.Download -Version 0.4.3-beta2 fixes the 'Could not find 7zip.exe in Xamarin installation' error; but now I'm getting errors like this after adding Google Maps (VS 2017).

    Unpacking failed. Please download 'https://dl.google.com/dl/cpdc/1204948f0f6ac434/GooglePlaces-2.1.0.tar.gz' and extract it to the 'C:\Users\xxx\AppData\Local\XamarinBuildDownloadCache\GPlcs-2.1.0' directory and create an empty file called 'C:\Users\xxx\AppData\Local\XamarinBuildDownloadCache\GPlcs-2.1.0.unpacked'

    When I download the .tgz file listed in the error message, it contains a .tar file with embedded symlinks - how do I extract this on Windows 10 and keep the file / link structure?

  • BillHolmesBillHolmes Xamurai USXamarin Team Xamurai

    PhilMitchell.0684,

    This is the remaining bug that we are working on. The fastest workaround is to run VS as administrator.

    You can also follow the instructions in the error message and extract the files manually. I do not believe that you need to worry about the links. We are not (should not) be using the links. If you really want the links you can manually extract with 7zip but again you will have run 7zip as an admin. https://superuser.com/a/1076531

  • BillHolmesBillHolmes Xamurai USXamarin Team Xamurai

    We have released 0.4.3-beta4 for Xamarin Build Download. I think we have addressed all the known issues. Looking to get some testing from the community before we drop the pre-release marker. Let us know how it goes for you all. We will be running some tests tomorrow and hope to release soon.

  • rmahaffeyrmahaffey ✭✭ USUniversity ✭✭
    edited March 2017

    I've got two build systems that have this problem, and one build system that doesn't. I have tried most, if not all, suggestions, pre-release NuGet's, clear Mac build cache, clear NuGet cache, restart VS as administrator, ... to no avail. Still scratching my head.....

    Just downloaded Xamarin.Build.Download 0.4.3, does not work. Are there certain steps that need to be done to make this work?

    What could I compare on the machine that does work versus the machine(s) that don't work? All three machines using the same source code but obviously something is different with the one that works.

  • rmahaffeyrmahaffey ✭✭ USUniversity ✭✭

    "packages\Xamarin.Build.Download.0.4.3\build\Xamarin.Build.Download.targets(51,3): error : Could not find 7zip.exe in Xamarin installation"

    Still seeing this issue, with a caveat, from the command line using msbuild in Jenkins. Not seeing the issue within Visual Studio IDE or DOS shell...

    What was the root cause of this issue? Did it have anything to do with $VsInstallRoot?

    My User7ZipPath does not look right below when I define it, it causes other errors.

    Task Parameter:DestinationBase=C:\Users\administrator\AppData\Local\XamarinBuildDownloadCache\ (TaskId:2489)
    Task Parameter:CacheDirectory=C:\Users\administrator\AppData\Local\XamarinBuildDownloadCache\ (TaskId:2489)
    Task Parameter:User7ZipPath=\Common7\IDE\Extensions\Xamarin.VisualStudio\7-Zip\7z.exe (TaskId:2489)

  • IPSIPS USMember

    I Have Face Couldn't Find 7zip.exe in xamarin Pls Help me

  • GVxGVx ✭✭✭ USMember ✭✭✭

    I get this error....

    packages\Xamarin.Build.Download.0.2.1\build\Xamarin.Build.Download.targets(25,3): error : Could not find 7zip.exe in Xamarin installation

  • GVxGVx ✭✭✭ USMember ✭✭✭

    Updated to the latest Xamarin.Build and now I get this...

    Xamarin.Build.Download.0.4.4\build\Xamarin.Build.Download.targets(55,4): error MSB4064: The "User7ZipPath" parameter is not supported by the "XamarinDownloadArchives" task. Verify the parameter exists on the task, and it is a settable public instance property.

  • mafmaf ✭✭ USMember ✭✭
    edited July 2017

    I installed VS 2017 on a freshly-reimaged machine and I'm getting "Could not find 7zip.exe in Xamarin installation" when trying to build iOS app.

    EDIT: Was due to a stale nuget package. After updating Xamarin.Build.Download, it works.

  • devgendevgen ✭✭ CHMember ✭✭

    Hi,

    I continuosly getting the error "The "User7ZipPath" parameter is not supported by the "XamarinDownloadArchives" task. Verify the parameter exists on the task, and it is a settable public instance property."

    I really don't know how to fix it. Can anyone help me?

    Really thanks

Sign In or Register to comment.