which version compatible with visual studio 2012 ??

AdamHumanAdamHuman USMember
edited February 2017 in General

hi all
i have visual studio 2012 ( Ultimate Version ) , and i installed Xamarin last version
and when i open android project in visual studio
a message appear to me said that i'm not allowed to use Xamarin on VS 2012 !!!!!!!!
"and i dont like to work on VS 2015"
so which version of Android Xamarin is compatible with vs 2012 ??

Answers

  • AlessandroCaliaroAlessandroCaliaro ITMember ✭✭✭✭✭
    I think none. You can download 2015 or 2017
  • AshleyGazichAshleyGazich USMember, Xamarin Team Xamurai

    Hi Adam! The minimum requirement is a non-express edition of Visual Studio 2013 Update 2. The full requirements can be found here.

  • DaveHuntDaveHunt USMember ✭✭✭✭✭

    @AshleyGazich said:
    Hi Adam! The minimum requirement is a non-express edition of Visual Studio 2013 Update 2. The full requirements can be found here.

    Someone needs to update the FAQ:

    What are the minimum system requirements?
    Xamarin requires the platform SDKs from Apple and Google to target iOS or Android, and our system requirements match theirs. To build for iOS, you'll need the latest iOS SDK (currently iOS 9.1), which ships with Xcode 7.1 and requires Mac OSX 10.10.5+ (Yosemite) or 10.11 (El Capitan). Our Visual Studio Extensions for iOS and Android support any non-Express editions of Visual Studio 2012, Visual Studio 2013, and Visual Studio 2015 (Community, Professional, and Enterprise).

  • AshleyGazichAshleyGazich USMember, Xamarin Team Xamurai

    To clarify, the Visual Studio 2013 Update 2 requirement is for the new licensing structure corresponding to the "Xamarin for Everyone" announcement. Visual Studio 2012 support was targeted toward legacy Xamarin subscribers.

  • SteveMcKisicSteveMcKisic USMember ✭✭

    So, let me get this straight. Microsoft - the creator of Visual Studio 2012, a product whose support lifecycle for the latest update is still active - purchases Xamarin, and then drops VS2012 Xamarin extensions.

    Pardon my French, but wut da fudge. Thanks, Microsoft. Thank you.

  • SteveMcKisicSteveMcKisic USMember ✭✭

    And something I find hysterical about all this... I have installed VS2015 and attempted to install the latest version of Xamarin (Xamarin.VisualStudio_4.3.0.784.msi), but after repeated attempts, the installation continues to fail. After looking through the install logs, check out the following:

    [2017-03-03 06:41:06.360] [Debug] Will install Visual Studio 2012 extension
    ...
    [2017-03-03 06:41:06.588] [Exception] System.InvalidOperationException: MSI execution failed.
    ...
    [Info] The installer has encountered an unexpected error installing this package. This may indicate a problem with this package. The error code is 2711. The arguments are: Xamarin_VS11_AddIn

    So, if I understand correctly, not only does the new Xamarin VS Installer - which explicitly does not support VS2012 - detect the presence of VS2012, it attempts to install the VS2012 extension and then fails the installation when trying to do so.

    Does installing the latest version of Xamarin for Visual Studio require uninstalling VS2012?

  • AshleyGazichAshleyGazich USMember, Xamarin Team Xamurai

    Hi Steve, if this is still an issue, is Visual Studio 2012 deselected (with red X) in the installation wizard?

Sign In or Register to comment.