Xamarin Studio hangs on loading when opening project

I have a project that I have been working on, with shared code on Android and IOS
I had this issue before, that when opening the project it just hangs on loading.
Now it is stuck again. Just hangs when opening project and "Loading" OR "Loading workspace documents"

How do I solve this.
I just bought a new license and expect this to work.
No fancy stuff in here. just standard json and sqlLite

Anyone have a solution?

Posts

  • LluisSanchezLluisSanchez ESXamarin Team Xamurai

    Can you attach the Ide log file? To get it, click on the Help menu and then in Open Log Directory.

  • ta.speot.ista.speot.is AUMember

    I have this issue too - on my Mac Mini at home (which has been around for a while) and a new Mac Mini we have at work.

    Hangs for no good reason. It seems to coincide with package restore/checking for package updates but I feel that's a coincidence.

    I had a look at Ide.log - the latest is useless ("you just started XS!") but I found an older one that appears to show the problem. A few threads seem to be in a wait state (e.g. WaitOne_internal).

    It doesn't look like there's any sensitive information in the log but I'm not confident of this. Can you please email me at t AT speot DOT is and I'll send the log to you.

  • YairCleperYairCleper ILMember

    So.... it's 26/11/2015 and I had the same error with Xamarin Studio v5.10 (build 871) ...
    Editing the .userprefs file (exists right next to the .sln file) by removing all open documents under the tag solved the startup hang issue.

    My 2 cents..

  • AnthonyJanssensAnthonyJanssens BEUniversity ✭✭

    @YairCleper you are a star !

    Xamarin studio was hanging as soon as I opened my solution and there was nothing I could do until I came across your solution and thought "what the heck, let's give it a go".

    Incidentally I had switched branches on my repo before re-opening the solution so maybe XS got confused.
    Another thing I noticed was that there were a lot more "open files" in the .userprefs than were actually open when I opened XS.

    Thanks again @YairCleper , I really needed to get working on this project and you saved me precious time!

  • JeremyMaloufJeremyMalouf USMember ✭✭

    Hi - I'm having the same issue but editing the .userprefs file didn't do it for me :(

    I changed update stream to 'Alpha' and I was actually able to open the project finally! However shifting back to 'Stable' causes the problem to come back again!

    This affects every single one of my projects and I can't even create a new solution (Hangs after pressing 'Create' on the 'Configure your new project screen).

    This is at the end of the ide log file: WARNING [2017-03-10 10:42:16Z]: Project has no solution. Using project directory as base directory for NuGet. Project: '[project directory].csproj'

  • JGoldbergerJGoldberger USMember, Forum Administrator, Xamarin Team, University Xamurai

    @JeremyMalouf

    Thanks for reporting this issue.

    I don't think that line from the logs is very relevant. First it is a warning not an error and it is letting you know that there is no solution file/folder ( I assume you are opening a .csproj file rather than a .sln file? ) and that due to that NuGet will use the project directory as the base directory for NuGet (i.e. where the packages folder will go).

    I can not reproduce the issue about the inability to create a new solution. It might help to get your logs and version info. Also what type(s) of projects are you trying to open that do not open, e.g. iOS, Android, Console, etc?

    IDE Logs

    In Xamarin Studio, use the Help->Open Log Directory to open the log folder. Zip up all of the ide.log files.

    Version Info

    In Xamarin Studio (Mac), version information can be obtained by navigating to: Xamarin Studio -> About Xamarin Studio -> Show Details -> Copy Information button.

    If you do not want to share logs/version info publicly, you can PM me.

  • JeremyMaloufJeremyMalouf USMember ✭✭

    Thanks Jon! PM sent

  • JeremyMaloufJeremyMalouf USMember ✭✭

    I just restarted my computer and the problem is gone! Thanks so much Jon!

Sign In or Register to comment.