Forum Cross Platform with Xamarin

iOS simulator to Windows fails

I have installed the last version of iOS simulator for Windows on VS 2015 Update3 and it fails at startup. First on the iOS simulator for Windows, i can see:

  1. Connecting to Mac ...
  2. Checking server...
  3. Connected
    After a little time i see the complete frame with the menus and the central Apple icon and later the message box:

Failed to install
ddddd8/bin/iPhoneSimulator/Debug/ to to OC9190C4-F507-41D8-9959-2B553FB9A64C

I tried to delete the folder 'bb4455981a4b47b86c93f2eee2ddddd8' on my mac host and to launch a new Mac iOS simulator debug session from VS to reload the folder content. The whole folder is copied afresh and the Mac iOS simulator '4s iOS 9.3' works fine but when i am trying a new 'remote logging' the iOS simulator for Windows fails with the same message :(


  • tiagoyfttiagoyft PTMember ✭✭

    I'm having the same problem did you find a solution ?

  • JFCJFC USMember ✭✭

    Yes !
    I had only 2Gb of RAM on my old MacMini(OS: ElCapitan), after upgrading to 8Gb all is working fine :)
    It seems that the MacOS needs too much memory to run a 'remote simulator' new session !?

  • JFCJFC USMember ✭✭

    In fact on my Mac (MacMini - ElCapitan 10.11.5) a remote session of 'iOS Simulator' use :
    3.10 GB of Memory
    + 2.60 GB of Cached Files
    For the initial use the Windows 'iOS remote simulator' seems very cool an easy to use :smiley:

  • BrandonMillerBrandonMiller USMember
    edited July 2016

    I don't think RAM is always the issue. I have 16gb of ram on my macbook. Check the activity monitor, there is only 5gb being used at the time I try to deploy using iPhoneSimulator on VS. Still, I get the same exact error. Is there absolutely no log file generated or ANY type of error/warning message?

    Also, I'm running Yosemite 10.10.5. Would that be an issue?

  • JFCJFC USMember ✭✭

    Brandon have you try to delete the folder '/Users/xxxxxxx/Library/Caches/Xamarin/mtbs/builds/XamarinPortableiOS/yyyyyyyyyyyyyyyy/bin/iPhoneSimulator/Debug/' on your Mac ?
    After the folder deletion the debugging system first creates afresh folder for you debugging application, writing the 'updating...' message on the remote simulator.
    Perhaps if it fails you will see some error messages on the Mac 'Console' tool filtering by 'Xamarin 4.1' !?

  • VikasAgarwalVikasAgarwal INMember ✭✭

    @SiavashGhassemi I follow your solution and put my mac user name as FullName, and reconnect mac with visual studio.
    Still getting same error.
    Any one found solution regarding this error.

  • LyndonHugheyLyndonHughey USUniversity ✭✭✭

    I'm also experiencing this error. Changing my fullname to the username, but it didn't fix the issue.

  • RaymondKellyRaymondKelly USMember ✭✭✭

    Anyone have luck with this issue. I am also having "Install Failed"

  • JaikishenJJaikishenJ USMember

    Hi Guys, I just downloaded VS2017 enterprise edition and connected to the mac agent, built the code, simulator came up and boom.. got the same error. Any one from the Xamarin team have any solutions/work arounds for this?

Sign In or Register to comment.