Forum Visual Studio

Visual Studio 2017 stucks on Xamarin Andorid Settings

I just installed Visual Studio 2017 with Xamarin. Because I have downloaded and installed JDK, Android SDK and NDK I have unchecked those packages in the installer.

I tried to create a Xamarin.Forms project in VS2017 but it had stuck on "Creating a new project" for couple of minutes and there was no luck! I've checked Xamarin logs and I understood Xamarin cannot find JDK, Android SDK and NDK paths.

When I about to open Android Settings in Visual Studio to set those paths, VS2017 again hangs forever. What I have had done wrong?

PS:
I attached Visual Studio 2017 and Xamarin logs.

Best Answer

  • AliBahraminzhad.1068AliBahraminzhad.1068 USMember
    Accepted Answer

    OK!
    I just solved the problem by setting Windows Registry Keys for AndroidSdkDirectory, AndroidSdkDirectory

Answers

  • AliBahraminzhad.1068AliBahraminzhad.1068 USMember
    Accepted Answer

    OK!
    I just solved the problem by setting Windows Registry Keys for AndroidSdkDirectory, AndroidSdkDirectory

  • Mark.2757Mark.2757 CNMember

    @AliBahraminzhad.1068 said:
    OK!
    I just solved the problem by setting Windows Registry Keys for AndroidSdkDirectory, AndroidSdkDirectory

    I had got the same issue. Can you give more details about how to set the AndroidSdkDirectory? THX.

  • AhdzleeAhdzlee USMember

    Thanks @AliBahraminzhad.1068 for the hint on setting AndroidSdkDirectory on the registry.

    To all who might face the same issue, I was able to solve mine by setting and/or adding the following registry values under "HKCU\SOFTWARE\Xamarin\VisualStudio\15.0_xxxxxxxx\Android" key

    • AndroidSdkDirectory
    • AndroidNdkDirectory
    • JavaSdkDirectory

    Hope this helps.

    Cheers!

  • @Mark.2757 said:

    @AliBahraminzhad.1068 said:
    OK!
    I just solved the problem by setting Windows Registry Keys for AndroidSdkDirectory, AndroidSdkDirectory

    I had got the same issue. Can you give more details about how to set the AndroidSdkDirectory? THX.

    You need to set keys @Ahdzlee mentioned in the registry to solve the problem.

Sign In or Register to comment.