SVN broken in Xamarin Studio 6.0

KjellAnderssonKjellAndersson SEMember
edited May 2016 in Visual Studio

I just switched over to the beta channel for Xamarin Studio Professional (Mac OS X) and use version 6.0 (build 5166) in order to get around some bugs in version 5.
The SVN integration however does not seem to be working in that version. The SVN plugin (Subversion support) is green in the Add-ins / Version Control dialog but I am unable to use SVN.

The project I was working on in version 5 was able to use the SVN version control, but now it just says that the project is not under version control when using version 6.

Is the SVN plugin not compatible with the beta channel versions?


  • KjellAnderssonKjellAndersson SEMember

    I found this post:
    After running "xcode-select --install" SVN worked in Xamarin Studio again.

  • LuiginoDeTogniLuiginoDeTogni USMember ✭✭

    Yes! It works for me too.

  • ZmasterZmaster USMember ✭✭

    Fixed it for me as well, thank you!

  • RexluvplayRexluvplay CNMember
    edited June 2016

    Fixed it by this way.
    It was a real big shock to me when I updated Xamarin to 6.0 and SVN didn't work...
    @KjellAndersson You saved me!
    Thanks a lot!

  • AllanChin.6924AllanChin.6924 USUniversity ✭✭✭

    I'm having this problem now, I'm guessing going from Xamarin Studio Community to Enterprise. But when I run the "xcode-select --install" command, I just get this.

    hpadmins-Mac-mini:Gotham_Mac_Prototypes hpadmin$ xcode-select --install
    xcode-select: error: command line tools are already installed, use "Software Update" to install updates
    hpadmins-Mac-mini:Gotham_Mac_Prototypes hpadmin$

    Any other suggestions?


  • AllanChin.6924AllanChin.6924 USUniversity ✭✭✭

    The Subversion option doesn't appear anywhere (Check-out nor Publish) within Xamarin Studio, except for the Add-in manager where it appears supported and enabled. Here's my environment.

    === Xamarin Studio Enterprise ===

    Version 6.2 (build 1821)
    Installation UUID: 6679460b-ef93-4286-bfaa-e1c265c1cd08
    Mono 4.8.0 (mono-4.8.0-branch/e4a3cf3) (64-bit)
    GTK+ 2.24.23 (Raleigh theme)

    Package version: 408000495

    === NuGet ===


    === Xamarin.Profiler ===

    Version: 1.2.0
    Location: /Applications/Xamarin Profiler

    === Apple Developer Tools ===

    Xcode 8.2.1 (11766.1)
    Build 8C1002

    === Xamarin.Mac ===

    Version: (Visual Studio Enterprise)

    === Xamarin.Android ===

    Version: (Visual Studio Enterprise)
    Android SDK: /Users/hpadmin/Library/Developer/Xamarin/android-sdk-macosx
    Supported Android versions:
    6.0 (API level 23)

    SDK Tools Version: 25.2.3
    SDK Platform Tools Version: 25.0.1
    SDK Build Tools Version: 25.0.1

    Java SDK: /usr
    java version "1.8.0_101"
    Java(TM) SE Runtime Environment (build 1.8.0_101-b13)
    Java HotSpot(TM) 64-Bit Server VM (build 25.101-b13, mixed mode)

    Android Designer EPL code available here:

    === Xamarin Android Player ===

    Not Installed

    === Xamarin.iOS ===

    Version: (Visual Studio Enterprise)
    Hash: 35d1ccd
    Branch: cycle9
    Build date: 2017-02-16 17:40:00-0500

    === Xamarin Inspector ===

    Hash: cdc01b9
    Branch: 1.1-release
    Build date: Wed, 22 Feb 2017 23:24:11 GMT

    === Build Information ===

    Release ID: 602001821
    Git revision: d41b6e51f3fa46a1943f2e31a778d28a7c73d069
    Build date: 2017-02-17 15:18:19-05
    Xamarin addins: 1363a8d943bab7700c93a97474060b6734aa7f94
    Build lane: monodevelop-lion-cycle9

    === Operating System ===

    Mac OS X 10.12.3
    Darwin hpadmins-Mac-mini.local 16.4.0 Darwin Kernel Version 16.4.0
    Thu Dec 22 22:53:21 PST 2016
    root:xnu-3789.41.3~3/RELEASE_X86_64 x86_64

  • JGoldbergerJGoldberger USMember, Forum Administrator, Xamarin Team, University Xamurai


    This thread is a few months old. I would suspect that the original issue is different from what you are experiencing, and the original issue seems to have been that they did not have the XCode command line tools installed, and these are required for using SVN with Xamarin Studio, and that command installed them. Your XCode command line tools would appear to already be installed, so this is a different issue it would seem.

    As a first step, can you go over our guide on using SVN with Xamarin Studio?

  • JGoldbergerJGoldberger USMember, Forum Administrator, Xamarin Team, University Xamurai


    Just found another thread about SVN issues with Xamarin Studio 6.2. Please see:
    A bug report has been filed but it was filed as a private bug so you would not be able to see it.

    I am going to close this thread to move the discussion onto that other thread.

This discussion has been closed.