Forum Xamarin.iOS

New Install VS15 + Xamarin + XCode 8.2.1 Not working


I'm trying to get an answer on here before uninstalling this software and developing straight on Mac after spending 4 hours trying to figure this out. I just installed all these programs on both machines (VS15/Xamarin on Windows 10, Xcode/Xamarin on iMac, both on the same network). Mac Agent is connected, I have a Developer account on XCode, a device linked to my account, everything looks fine.

When I create a basic app (I don't even add a line of code, just a blank single view app) on XCode (iMac) and launch the simulator, it works just fine. I get the view of the device etc... When I do the same on my Windows machine, I can't debug. I get the error "The app could not be launched on 'iPhone SE iOS 10.2'. An error occurred while executing MTouch."

I looked all over the place searching for a solution. I removed the Entitlements.plist file, I also checked for updates on everything (as some suggested on StackOverflow). Nothing.

So I tried an Android app to see if that works and no issue there. I get the device I pick, shows a black screen because the app is empty, as expected.

If anyone can guide me before I uninstall this whole thing and code directly on a Mac, it would be greatly appreciated. Thank you!


  • JohnHJohnH GBMember ✭✭✭✭✭
    First thing to try is creating a new app on the Mac in Xamarin Studio. If that doesn't work then something is wrong with that installation. If it does work you know it's related to the link between your Visual Studio install and the Mac. But try that first and see.
  • justwilljustwill USMember

    Hey John,
    The simulator works on the Mac. I made a quick Hello World app and it launches fine.

  • JohnHJohnH GBMember ✭✭✭✭✭

    @justwill to be clear, you are referring to running the simulator from within Xamarin Studio on your Mac, right? Or just from Xcode like your first message says?

  • justwilljustwill USMember

    I mean from Xamarin Studio on my Mac. No problem experienced on Mac. That's what I'm using right now. I think I'll just give up on Xamarin iOS for Windows. I followed every advice from every forum where people experienced the same issue. Still not working...

    Thank you for your help though ;)

  • JohnHJohnH GBMember ✭✭✭✭✭
    edited February 2017

    @justwill It sounds like you are nearly there actually. Have you tried other simulators, actual device, rebooted etc.
    I flip between VS and XS often, depends on what I am doing.

  • justwilljustwill USMember

    I haven't tried other simulators but I did try my iPhone. Didn't work. I'm sure it's not a major issue as it works with Android, but I also have a time schedule to abide by so I'm using the Mac now. I'm so close to throwing this thing out the window though lol

Sign In or Register to comment.