Error "Could not resolve mscorlib for target framework '.NETCore, Version = v5.0'.

hz10hz10 USMember ✭✭

When adding a service reference to the UWP project of a Xamarin Forms project, I get the following error:

I added the latest version (5.0.1) of Microsoft.NETCore Nuget package, it did not resolve the problem, then changed the package to 5.0.0, and it failed to resolve the problem too.
I do not understand why it requires .NETCore. It is a typical UWP part of a Xamarin Forms project and targets Windows 10 (10.0; Build 10586).
Could anyone shed some light on this?

Answers

  • vbovbovbovbo CHMember

    Helllo,

    We got same problem few minutes ago. How i solved ?
    I go to the main app. Change Windows Version to Windows 10 instead Windows 8. I change the "deploy/debug" option in semi-selected to selected cases (square with black square to checked box).
    I clean the project, build the Windows Universal Platform, and worked.

    After, i go back to main project for change it to windows 8, but already changed in "windows 8". Strange.

    :smile:

  • vbovbovbovbo CHMember

    My colleague verified.

    Is just the "Clean" solution and after "Build" Windows Universal Platform solved this issue. :wink:

  • NMackayNMackay GBInsider, University mod

    Crikey that's almost standard practice when trying to compile and deploy in UWP :wink: throw into the mix that 70% of time you compile and deploy to a UWP mobile device Visual Studio crashes, still that's a known Microsoft issue they continue to ignore.

Sign In or Register to comment.