Droid Binding Library - Some code missing from the dll

BalinaBlintBalinaBlint USMember ✭✭

Hi!
I'm working on a project with Google Admob mediators. I am trying to use the Vungle SDK for both my iOS and droid project. Vungle has native SDKs for both platforms, which I need to embed into my Crossplatform xamarin project. I successfully dealt with iOS, with objective sharpie. However in the case of droid:

I added my jars and aar to to Binding Library, Built it successfully after some modification to the Metadata.xml, but I do not have all the code compiled which I need.

Here Vungle in says that I need to call vunglePub.init(...)

The above class does not appear in my generated c# code. I blamed the downloaded jars first, but after trying it in a native droid project using the same jars, it was clear that the jars are fine. The namespace, class, and functions are there.

The code I need is in vungle-publisher-adaptive-id-4.0.3.jar, which has a build action set to Embedded jar.

I tried to trick it with writing some fake metadata
<attr path="/api/package[@name='com.vungle.publisher']/class[@name='VunglePub']/method[@name='init' and count(parameter)=2]" name="managedReturn">bool</attr>
but this did not change anything.

Any help is appreciated,
Thanks!

Answers

  • BalinaBlintBalinaBlint USMember ✭✭

    Ok, some update here:
    I managed to resolve many issues, but they don't seem to have an end. With the 4 jars files + 1 aar, I still get 1000+ warnings on build on most of them seems irrelevant.
    The jars are also obfuscated, this makes it even harder.

    Can anybody give me suggestions, on how to get started to resolve these many issues?

Sign In or Register to comment.