Forum Xamarin.Forms

Hide menu (master) on master detail page for iPad landscape

JoshuaNovakJoshuaNovak USMember ✭✭

I know there are other pages that have brought this up, but they are all old posts so I figured i'd check again. Is there anyway to hide the menu (master) on the master detail page for iPad in landscape mode? I'm not sure why it is always shown since it is just taking up space that I actually need for the app. I just need a few navigation links there and I don't need them or want them there the entire time.


  • SapienDeveloperSapienDeveloper USMember ✭✭

    on your MasterDetailPage set the MasterBehavior setting to the behavior you need.

  • @SapienDeveloper, thanks for sharing your answer, it has been very helpful.

  • RogerSchmidlinRogerSchmidlin CHUniversity ✭✭✭

    It seems that this property can only be used in the constructor of the MasterDetailPage. It doesn't have any effect afterwards. My Master page is only relevant for the first Detail page. Once I navigate further on, I would like the Master page to disappear. I tried various things like setting the MasterDetailPage IsPresented to false. No effect either.
    Does anyone of you have another idea I could try?

  • JasonRodgersJasonRodgers USMember

    @SapienDeveloper That worked for me.... thanks

  • BenoistLUGNIERBenoistLUGNIER FRMember ✭✭

    That's work for me too Thanks
    Becarfull, the popupover is needed to show icones and titles

  • AlexBrownAlexBrown USMember ✭✭

    @RogerSchmidlin, I am with you - I am unable to create the behavior I desire.

    I have a tab page under a MasterDetail. Some tabs have menus, others do not. I want to hide the menu when on certain tabs. However, I like the MasterDetail Split behavior on Landscape Tablets and I want to keep that for the other tabs.

    If I change to Popover, it modifies it for all tabs, and I lose the desired split in tablet Landscape.
    If I keep it on Split, IsPresented seems to have no effect - The Master always shows regardless.

    I cannot nest the MasterDetail within the Tabbed Page because that creates undesireable behavior.

    Any suggestions?

Sign In or Register to comment.