Forum Visual Studio
We are excited to announce that the Xamarin Forums are moving to the new Microsoft Q&A experience. Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

We encourage you to head over to Microsoft Q&A for .NET for posting new questions and get involved today.

Getting an Error: Value Cannot be null. Parameter name: path1

while creating the new project i'm getting this error

Answers

  • AshwiniGuptaAshwiniGupta INMember

    help me to fix it.

  • sirboysirboy IQMember

    hi
    i have i same problem anybody can help?

  • Me too, please can help me, why i'm getting this error.
    Value cannot be null
    Parameter name:path1

  • ScottNimrodScottNimrod USMember ✭✭

    I am also getting this issue.
    I add a Xamarin.Forms project and I receive the error dialog.
    After clicking OK, I then observe that my Droid project is unloaded as a result of this issue.

    Any suggestions?

  • PhelixJanguPhelixJangu KEMember

    @AshwiniGupta said:
    while creating the new project i'm getting this error

    Try updating Android SDK Tools: go to Tools>Android>Android SDK Manager and update SDK Tools and SDK Platform-tools any other 'update available' tool.
    This worked for me, now my main challenge is that when I try to debug a default app, the 'Click Me' button, I get the following warnings:
    "No Android platforms installed at '{0}', Please install an SDK Platform witht he '{1}{2}tools{2}{3}' program." ...
    Could not determine $(TargetFrameworkVersion) for API level '-214.....'
    The referenced component 'Mono.Android' could not be found.
    The referenced component 'mscorlib' could not be found.
    The referenced component 'System' could not be found.
    The referenced component 'System.Core' could not be found.
    The referenced component 'System.Xml.Linq' could not be found.
    The referenced component 'System.Xml' could not be found.
    These references appear under References tree in the Solution Explorer but with a yellow icon.
    Any help will be much appreciated.
    Thank you and Happy New Year.

  • KraigBrockschmidt-MSFTKraigBrockschmidt-MSFT USMember, University ✭✭

    Also check the Android SDK location under Tools > Options > Xamarin > Android Settings. This is also a cause as described on http://stackoverflow.com/questions/32618851/unable-to-create-new-blank-app-android-in-visual-studio-2015. Doing updates in the Android SDK Manager can fix this automatically, but if you have the SDK packages you need, check this setting in Options too.

  • GregoryFeinGregoryFein USMember
    edited February 2017

    Edit: Deleted because wrong thread. Moved question to Xamarin forum (not VS): https://forums.xamarin.com/discussion/87815/cant-add-components-or-packages/p1?new=1

Sign In or Register to comment.