Forum Xamarin.iOS

"Error while creating this entry" on iOS Storyboard Segue Properties

Hi guys,

I'm having a strange issue with Xamarin.iOS in Visual Studio 2015.

If I select a segue on the Main.storyboard GUI, in the Properties window, some of the editable settings are missing, and just replaced with a "Error while creating this entry" error message (see image attached to post).

The segue is from a button to the next View/View Controller. The weird thing is that the solution still builds correctly, and is able to be sent for debugging to the Mac iPhone simulator just fine, including the segue when the button is pressed still working. But I can no longer edit those missing attributes in the Properties window... This isn't just limited to that one segue either, it's all the segues in the storyboard.

The other thing to note is that at the end of last week, everything was fine. I come in Monday, I haven't changed anything, but the Segues are now having this Properties window issue? Could it be some auto-updates on Windows or the Mac which caused this?

What I've tried so far to fix, or at least diagnose, it:

  • Deleting and re-adding the segue from the button to the next view.
  • Deleting the segue and just adding a segue from anything to anything else.
  • Restarting Visual Studio.
  • Restarting my computer.
  • Updating Xamarin for Visual Studio 2015.
  • Completely uninstalling and reinstalling Xamarin Studio on the linked Mac computer.

Nothing has yet fixed it. Any help in diagnosing this (I'm quite new to Xamarin and App Developing, generally, so it's possible it's something obvious I'm just not picking up) would be greatly appreciated.


  • DmitriyDmitriyDmitriyDmitriy USMember
    edited November 2016

    I have this problem too. who can help??

  • Same issue here, my push segue converts to popover and then when i reopen the storyboard, i have an error on the segue property.

  • KennyRayKennyRay USMember

    I am also having this exact problem!

  • I'm getting the same error.
    If I create the segue and click on it I will get the error message.
    If I save the storyboard and re-open it, the segue now displays correctly but if I add an identifier it goes nuts (you can see the screen change a couple times).

    I found that the mode will also be changed to popup but you can edit that directly on the file (opening it with a text editor). This is not ideal but it works for now.

  • twiggytwiggy GBMember

    I have the same issue and the same error messages, all my views are just 'partial' i.e. I cannot see 'all' of the view so cannot edit or add components. Build works fine & displays on iPad just fine. This looks like a known issue, anyone from Xamarin care to comment?

  • RandyPennerRandyPenner USMember

    I am having the same issue. Segue converts to popover and properties window displays error message "Error while creating this entry".
    Found no answers online, manual edit of storyboard file only option right now.

    Any fix for this yet?

Sign In or Register to comment.