Forum Visual Studio

Xamarin Studio keeps getting corrupted after completing in-app upgrade.

dbohlsdbohls USMember

Every time I attempt to upgrade Xamarin Studio on my MacBook Pro running Yosemite, I end up with a corrupted Xamarin Studio installation. After upgrading, the Xamarin Studio.app icon has a ghost buster and any attempt open causes OS X to popup an OK dialog saying:

"You can’t open the application “Xamarin Studio” because it may be damaged or incomplete."

I have to delete Xamarin Studio and reinstall using the Xamarin installer. I have attempted to archive the corrupted apps in case you want me file a bug report and attach them. Any advice for me to stop getting corruption? If I file a bug report, please let me know what all you would like included, such as the corrupted app or any install logs.

Posts

  • ErikBlanken.8685ErikBlanken.8685 USUniversity

    I am experiencing the exact same issue. Any updates?

  • dbohlsdbohls USMember

    This just stopped happening to me. I have no idea what changed. I still run Yosemite (just upgraded to 10.10.5). Sometime shortly after I made this post, in-app upgrades to Xamarin Studio just started working for me. I wish I could be of more help.

  • GaryCuevasGaryCuevas USMember ✭✭
    edited October 2016

    Same problem for me, MacBook Pro (mid 2015) with macOS Sierra. Did the same with Yosemite. HELP!!!!
    (Maybe not exactly the same problem - I can't get Xamarin Studio to run even once.)

  • NickTheileNickTheile USMember

    This same thing happened to me twice but i figured out how to fix it without doing a full re-install. I think when it tries to update it moves the Xamarin Studio.app down to a subfolder and renames it to Xamarin Studio (old).app. If something goes wrong during the install it does not move it back.

    These steps worked for me to resolve the issue:

    Goto Finder > Applications > Right Click "Xamarin Studio.app" > click "show package contents"

    You should see Xamarin Studio (old).app , If you click this it will open Xamarin Studio like normal.

    Then copy "Xamarin Studio (old).app" to the root of the Applications folder. Delete "Xamarin Studio.app" and rename Xamarin Studio (old).app to Xamarin Studio.app. Everything should work and you can open Xamarin Studio and try to update again.

Sign In or Register to comment.