Why won't my unit tests run on iOS10 when they run completely normal on iOS9?

CJensenCJensen USMember ✭✭

After a lot of tries to run trough different test on Xamarin and trying to execute them on a physical device with iOS10, I gave up. I was wondering if you could help me out.
So I am using Xamarin 6.1.3 build 19 and XCode 8.2.1. I am pretty sure that the problem is in the AppInitializer.cs.
In this application what we do is returning ConfigureApp.iOS.DeviceIdentifier().InstalledApp().StartApp();
The most usual error which appears after running a test is
SetUp : Calabash.XDB.Core.Exceptions.DeviceAgentException : Failed to install DeviceAgent

ExitCode: 9

/Users/Christian/Library/MobileDevice/Provisioning Profiles
app: /var/folders/3z/zvzqjcps4f99lvj29_67t36r0000gn/T/xdb/DeviceAgent.iOS.Dependencies/54daf9e58e37a80353a99c2b3139b615/ipa/DeviceAgent-Runner.app
device udid: fe3030ca596189c820b6cfe70fc7cad766e88659
-a,--app-bundle <path/to/app-bundle.app> Path .app bundle (for .ipas, unzip and look inside of 'Payload')
-c,--codesign-identity [OPTIONAL] Identity used to codesign app bundle [device only] DEFAULT=
-d,--device-id iOS Simulator GUIDs
-u,--update-app [OPTIONAL] When true, will reinstall the app if the device contains an older version than the bundle specified DEFAULT=1
install
Could not find any mobileprovision files in:
Could not find valid codesign identity
The folder “Provisioning Profiles” doesn’t exist.

Could anyone please help with realizing the issue?
Thank you in adcance!

Answers

  • JosNederlofJosNederlof USMember

    I got the same error.
    I tried a deleting the /var/folders/2t/fm9qys956l11rs0kcfm6gxf80000gn/T/xdb directory, but this didn't help.
    What to do next??

Sign In or Register to comment.