Vimeo video - galaxy S3 mini will not play

BazookasMobilestudioBazookasMobilestudio BEUniversity ✭✭
edited December 2014 in Xamarin.Android

Hey Forum,

I am trying to play a vimeo video in my android app, everything works fine on most devices but some, including the samsung galaxy s3 have issues with vimeo.
Whenever I click to play it just keeps on loading, after a couple more clicks on the play button it might or it might not start playing. This occurs for every vimeo video so I've already ruled out older vimeo videos. I get FileNotFoundException in my code but have no clue where that comes from. The error is listed below
I have also included the hardwareacceleration tag in my manifest. More detailed code can be found below.
Has anyone else had this issue before and what did you do to fix it?

Kind regards

Error:

[MediaPlayer] reset
[MediaPlayer] path is null
[MediaPlayer] setDataSource IOException happend : 
[MediaPlayer] java.io.FileNotFoundException: No content provider: http://pdl.vimeocdn.com/46088/518/318006375.mp4?token2=1419854186_2b753f1f15755574ad778da387ff75d3&aksessionid=d5695bf5baf3898b
[MediaPlayer]   at android.content.ContentResolver.openTypedAssetFileDescriptor(ContentResolver.java:761)
[MediaPlayer]   at android.content.ContentResolver.openAssetFileDescriptor(ContentResolver.java:665)
[MediaPlayer]   at android.media.MediaPlayer.setDataSource(MediaPlayer.java:960)
[MediaPlayer]   at android.webkit.HTML5VideoView.prepareDataCommon(HTML5VideoView.java:330)
[MediaPlayer]   at android.webkit.HTML5VideoView.prepareDataAndDisplayMode(HTML5VideoView.java:367)
[MediaPlayer]   at android.webkit.HTML5VideoInline.prepareDataAndDisplayMode(HTML5VideoInline.java:72)
[MediaPlayer]   at android.webkit.HTML5VideoViewProxy$VideoPlayer.play(HTML5VideoViewProxy.java:279)
[MediaPlayer]   at android.webkit.HTML5VideoViewProxy.handleMessage(HTML5VideoViewProxy.java:448)
[MediaPlayer]   at android.os.Handler.dispatchMessage(Handler.java:99)
[MediaPlayer]   at android.os.Looper.loop(Looper.java:176)
[MediaPlayer]   at android.app.ActivityThread.main(ActivityThread.java:5419)
[MediaPlayer]   at java.lang.reflect.Method.invokeNative(Native Method)
[MediaPlayer]   at java.lang.reflect.Method.invoke(Method.java:525)
[MediaPlayer]   at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:1046)
[MediaPlayer]   at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:862)
[MediaPlayer]   at dalvik.system.NativeStart.main(Native Method)
[MediaPlayer] Couldn't open file on client side, trying server side
[MediaPlayer] setVideoSurfaceTexture
[MediaPlayer] prepareAsync

Code:

 public class BazookasWebchromeClient:WebChromeClient
        {
            public override void OnProgressChanged(WebView View, int newProgress){
                Console.WriteLine (newProgress);
                base.OnProgressChanged (View, newProgress);
            }
        }
        public class VideoHolder :AbstractHolder
        {
                public override void SetView(View convertView)
                {
                    VideoWebView = convertView.FindViewById<WebView> (Resource.Id.wv_li_video);
                }
                public override void SetData(bzVideo video){
                    VideoWebView.SetWebViewClient (new WebViewClient ());
                    VideoWebView.SetWebChromeClient (new BazookasWebchromeClient ());
                    VideoWebView.Settings.JavaScriptEnabled = true;
                    VideoWebView.Settings.SetAppCacheEnabled(true);
                    VideoWebView.Settings.DomStorageEnabled = true;

                    VideoWebView.Settings.SetPluginState (WebSettings.PluginState.On);
                    prevURL = "http://player.vimeo.com/video/" + video.timelineVideoLocation;
                    //VideoWebView.LoadData("<iframe src=\""+prevURL+"\" width=\"180px\" height=\"180px\" frameborder=\"0\" webkitallowfullscreen mozallowfullscreen allowfullscreen></iframe>","text/html", "utf-8");
                    VideoWebView.LoadUrl (prevURL);
                }
        }

Posts

  • Any solution for this ??

  • I'm having that issue right now, also with Vimeo. No one found a solution yet?

    Microsoft Visual Studio Professional 2015
    Version 14.0.25431.01 Update 3
    Xamarin 4.2.1.73 (fa989ec)
    Xamarin.Android 7.0.2.37 (ce955cc)

  • BazookasMobilestudioBazookasMobilestudio BEUniversity ✭✭

    We have not found a solution for this yet but are hard working on one.
    Tests from java-android apps have revealed the same issue so this is not a Xamarin only issue.

Sign In or Register to comment.