Forum Visual Studio

Root element is missing

Hi everyone

I don't know if this is the right forum to post this question, but I have a problem when creating a new UWP-project in my solution. Every time I add a blank Universal Windows app I get the error "Root element is missing".

Uninstalling and reinstalling Visual Studio 2015 doesn't work... What could be the problem?


Best Answer


  • kentuckerkentucker USMember ✭✭✭✭✭

    Try using the visual studio uninstaller on github to remove visual studio and try installing it again.

  • ClintStLaurentClintStLaurent USUniversity ✭✭✭✭✭


    I have a problem when creating a new UWP-project in my solution

    What do you mean you're adding a new UWP project to an existing solution? When you make a new Xamarin.Forms solutions doesn't it already have a UWP project? The UWP project is part of the Visual Studio solution template.

  • StefaanAvonds.3725StefaanAvonds.3725 USMember ✭✭✭


    When creating a new Xamarin.Forms solution it does want to add a UWP project, but the same error occurs. so in no way is it possible to create a UWP project...

    I'll try your solution.

  • StefaanAvonds.3725StefaanAvonds.3725 USMember ✭✭✭

    Not working. Still the same error "Root element is missing".

    What's odd is that upon creating a new Xamarin.Forms solution Visual Studio does create a UWP-folder in the File Explorer and everything seems right. Only does VS immediately generate the error message "Root element is missing" and doesn't add the project in the Solution Explorer. This project cannot be added, since the same error occurs.

  • kentuckerkentucker USMember ✭✭✭✭✭

    Do you get a dialog asking which version of windows 10 to target?

  • StefaanAvonds.3725StefaanAvonds.3725 USMember ✭✭✭

    Yes. The options "Windows 10 (10.0; Build 10240)" and "Windows 10 (10.0; Build 10586)" are available.

    In ActivityLog.xml another error is visible:

        <time>2017/01/02 10:38:33.933</time>
        <source>Extension Manager</source>
        <description>Extension will not be loaded because an extension with the same ID &apos;Microsoft.Windows.DevelopmentKit.Desktop&apos; is already loaded at C:\PROGRAM FILES (X86)\COMMON FILES\MICROSOFT\EXTENSIONMANAGER\EXTENSIONS\MICROSOFT\WINDOWS KITS\8.1\DESKTOP SDK\...</description>

    And indeed both extension.vsixmanifest-files are the same... is this normal or could this be the problem?

  • kentuckerkentucker USMember ✭✭✭✭✭

    Try installing the latest win 10 sdk (ver. 10.0.14393.0) . Hopefully it will resolve the issue.

  • StefaanAvonds.3725StefaanAvonds.3725 USMember ✭✭✭

    The latest SDK is installed, but still the same error...

    Control Panel displays the following:
    1. Windows Software Development Kit - Windows 10.0.10586.212
    2. Windows Software Development Kit - Windows 10.0.14393.33
    3. Windows Software Development Kit - Windows 10.0.26624

  • kentuckerkentucker USMember ✭✭✭✭✭

    only thing else I can suggest is to uninstall the 3 win 10 sdks and install them again in the order they were released

Sign In or Register to comment.