xaml not working at all

so i make a new app project, tell it to go to pagex then put a label on that page saying hi.
okay, it works, after a while, like, half an hour, it doesn't work anymore.
whenever i open the app, it's just blank. funny thing is that i ctrlz to when it's written "welcome to xamarin!" in c#, it works ok.
So my guess, is that only the xaml/xml file aren't working, but out of nowhere? it happened on VS 2015, i reformated my pc, installed VS 2017 RC and its the same sh... Please help me, it's been like this for 4 days now, i've reinstalled xamarin and VS in so many ways in so many time i can't even count, i really want to like this IDE, but i'm just tired...

again: I make a project, i write something and it works, after a while, let's say, if i take a 2hour nap and come back without even touching, just visual studio open, the emulator(android) on the background, if i try to run the app, it will run, but if i change anything, even a letter on the

yes, i've reinstalled VS, i've reformated windows (10 pro), i've rebooted, i've restarted VS, i've talked to satan and god, i've literally cried out of stress (not kidding, i'm at a low connection it took me 27 hours to download VS2017 just to freaking have the same error) i'm kinda noob, i'm learning (as you can see from my code) but seriously...

My pc specs (even tho i don't think it's needed) are, GTX 960, i5 4570T, 6gb ram 1333mhz

code for app.cs:

namespace App5
{
public class App : Application
{
public App ()
{
// The root page of your application
MainPage = new Page1();
} ... rest is just what it comes with.

Page1.xaml
<?xml version="1.0" encoding="utf-8" ?>

<ContentPage.Content>

    <Label Text="oi"/>
</ContentPage.Content>

Page1.xaml.cs is just blank how it was created

Tagged:

Answers

  • ClintStLaurentClintStLaurent USUniversity ✭✭✭✭✭

    @MatheusDuarte
    My first guess is you have black text on a black page and it only looks blank.
    Set the TextColor to white.

    In the future it would help if you used the markdown tags for your code rather than relying on the forum parser to guess where your code starts and stops. As you can see looking at your post, the code is pretty mangled.
    XF_codetags.png

  • @ClintStLaurent Nope
    You did read the post saying that it goes blank out of nowhere, changing no code but only whats written in the text?

  • ClintStLaurentClintStLaurent USUniversity ✭✭✭✭✭

    @MatheusDuarte said:
    @ClintStLaurent Nope
    You did read the post saying that it goes blank out of nowhere, changing no code but only whats written in the text?

    Honestly (and sorry if this hurts your feelings) reading your post is just painful. I'm not a fan posts written like they are text messages. I got about as far as "i cntrlz to when" and nearly closed the page rather than spend time on the question. Just being straight with you.

    What I did read was your posted code (and screen capture) showing that you weren't explicitly setting the color.

    So that was, as I said, my first guess.

    Frankly... Its an emulator. Nobody expect much of emulators. The first reply tends to be "Does it work on a physical device because emulators are unreliable." So... Does it work on a physical device? Does a real phone/tablet have the same issue? Does the UWP project work fine on the same PC?

    What are the sleep/screensaver/power options on the emulator? Maybe its just going to sleep and not waking correctly. Maybe its a driver issue with your PC (that comes up a lot with emulators). 6gig of RAM isn't much for development: Maybe you're running low over time and the emulator get's the short end of the stack.

    There's bunches of things that can kill an emulator, especially on a machine with lower power specs. See what it does on a physical machine before you worry too much about it.

    Maybe this set up tutorial will help.
    https://redpillxamarin.wordpress.com/2016/12/23/202-starting-on-the-right-foot/

  • @ClintStLaurent said:
    Honestly (and sorry if this hurts your feelings) reading your post is just painful. I'm not a fan posts written like they are text messages. I got about as far as "i cntrlz to when" and nearly closed the page rather than spend time on the question. Just being straight with you.

    It doesn't hurt as much Xamarin does, It doesn't run on device.

  • 3pa23pa2 USMember ✭✭

    Test deleting obj folder and rebuild and then run

Sign In or Register to comment.