Error when open android main design on visual studio 2015

I want to develop an android application using Xamarin Visual Studio 2015, but i have a problem when i open layout design in visual studio, that layout cant show and have a error. How to fixed it ? i still confused, because im new in using xamarin. Thank You


  • lukasrein97lukasrein97 USMember ✭✭✭

    The best thing you can do is to Update Xamarin and Download all nessesarry things from your Android SDK Manager.
    When all is downloaded and installed and the error isnt gone please show it us here with more information.

  • SetiawanHanSetiawanHan USMember
    edited December 2016

    I have been Update all of SDK Manager and Xamarin, but i have an error like this. (Attach Pict). Please suggest me, how to fix it.
    Image 1 ( --> When i open android layout designer, i have a problem like that.

    When i checked my android sdk, java, ndk Image 2 ( my directory is correct place. please give me more solution to fixed it. Thanks

  • lukasrein97lukasrein97 USMember ✭✭✭

    java.lang.NoClassDefFoundError This exception indicates that the JVM looked in its internal class definition data structure for the definition of a class and did not find it. This is different than saying that it could not be loaded from the classpath. Usually this indicates that we previously attempted to load a class from the classpath, but it failed for some reason.

    Im looking into it for a solution.

  • Any solution yet, same problem

  • AlanClarkAlanClark USMember ✭✭✭

    @MorneOdendaal The first thing I'd try is to close the project, navigate to the project location in File Explorer and remove your 'bin', 'obj' and 'packages' folders. Open the project in Visual Studio again. NuGet should pull the packages back down.

    Can you try that and let me know how it goes?

  • MorneOdendaalMorneOdendaal USMember
    edited December 2016

    Ok found the reason and solution, after updating the java sdk's the pointer from visual studio to the java development kit was still pointing to the old sdk. After changing that under "Tools -Options-Xamarin- Java development kit location" in Visual Studio the problem was sorted out. :) Hope this helps anyone who run to this in future.

Sign In or Register to comment.