Forum Visual Studio

Xamarin Android project recognized as "Miscellaneous files"

I am working on a Xamarin shared project cross-platform app. Development has come to a standstill now as the files under Xamarin Android project are being recognized as "Miscellaneous files" in Visual Studio. All the Nuget references in the Android project are now throwing an error. There are a few other issues with the code, however, all of them can be fixed only if this project reference error is fixed first. I have attached a screenshot of my visual studio that depicts this problem.

The code is available in github:
The branch is AndroidIosViewModels.

I have tried

i) Reinstalling visual studio
ii) Updating visual studio
( I tried it in Visual studio 2015 Update 1,2 & 3)
iii) Updating Xamarin ( Even tried the preview version)
iv) Cloning the repository in a different directory
v) Creating a new project and copying the various files one by one into it.
vi) Checking if the csproj files have the proper reference
vii) Manually adding and removing entries to the csproj file
viii) Cloning the repository in C drive itself, just to check if long path names were a problem.

I found this stackoverflow post that is similar to my situation: However, even that did not work.

I am at a loss on what to do next. Please help

Current Visual Studio Version: Visual Studio 2015 Update 3 Enterprise Edition
Current Xamarin Android Version: 6.1.99
OS: Windows 10 & Mac

While Visual studio is being used to develop the Android part of the project, the same project is being worked on Xamarin Studio for the iOS version.

Best Answer


  • JamesMontemagnoJamesMontemagno USForum Administrator, Xamarin Team, Developer Group Leader Xamurai

    In your references do you see "Mono.Android" ? If you go to add a reference to do you see it in there?

  • ArunBalajiArunBalaji USMember

    Thank you all. My problem has been resolved. I had to clear VS2015 cache first.

    For those who have a similar problem, this is what I did

    i) Clear the cache
    ii) Open the solution
    iii) Unload all projects
    iv) Load Android project and then fix nuget references
    v) Once the references were fixed, I loaded the shared project. Now everything seems to work.

    Thanks for your help!


  • Nick2016Nick2016 USMember

    Hi Arun,

    I am having the same issue for all my NEW projects. All class files are classified into "miscellaneous files" in Android project. It happens after update Xamarin a couple of days ago. With the most updated Xamarin I have the same issue.

    I tried to clear the "componentmodelcache", reset the user environment, and nothing helped.

    How did you clear the VS cache at that time?



  • WilsonHuangWilsonHuang USMember ✭✭
    edited December 2016

    Hi, Nick,
    Try to install jdk1.8.0_112. You can download it from
    Choose jdk-8u112-windows-i586.exe
    After you install jdk 1.8 change your Xamarin JDK location to jdk 1.8, then rebuild your Android Project, the error should disappear. Hope that helps!
    You can uninstall old jdk if you want to.

Sign In or Register to comment.