Connection to the layout renderer failed. This may be caused by a misconfiguration of Java. (Error).

Hi, I have faced the fallowing error when creating axml layout file and trying to open it in designer view. I have tried to install the newest JDK as well as downgrade it and etc, does not change anything the error message persists. As well I have tried to add an environmental variable _JAVA_OPTIONS and experiment with the value. I have managed to found other solutions on the forum but they were not applicable to my case as I am using Visual studio 2015 to develop. Before asking this question I have really searched this forum and tried what could have been done still nothing.

This is the message I get as well:

java.lang.NoClassDefFoundError: com/android/utils/ILogger
at java.lang.Class.getDeclaredMethods0(Native Method)
at java.lang.Class.privateGetDeclaredMethods(Class.java:2701)
at java.lang.Class.privateGetMethodRecursive(Class.java:3048)
at java.lang.Class.getMethod0(Class.java:3018)
at java.lang.Class.getMethod(Class.java:1784)
at sun.launcher.LauncherHelper.validateMainClass(LauncherHelper.java:544)
at sun.launcher.LauncherHelper.checkAndLoadMain(LauncherHelper.java:526)
Caused by: java.lang.ClassNotFoundException: com.android.utils.ILogger
at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:331)
at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
... 7 more
Error: A JNI error has occurred, please check your installation and try again
Java HotSpot(TM) 64-Bit Server VM warning: ignoring option MaxPermSize=350m; support was removed in 8.0
Exception in thread "main"

Best Answer

Answers

  • Hello Vlad,

    I am new to Xamarin and I have same problem as you have described. Could you be kind to include instruction step by step how to fix the issue?

Sign In or Register to comment.