Auto-completion a little buggy+aggressive, and any ways to configure this?

With the latest update (5.5.3 build 6), the problem is particularly bad, as auto-complete seems have some particular bugs such that it's turning what I write into some different auto-complete string often when it really definitely shouldn't ... like normally it only tends to do so when what I write is like some variable/method that doesn't exist, or when there's other errors in code, but now it seems to be doing it all the time.

But generally even when it is working as apparently designed, I find that its often quite annoying how it always wants to aggressively change what I'm writing into some autocompletion. For example, if I want to write some code to call a method, but I haven't defined that method yet (probably I will shortly, but I might want to write the code using it first in this instance), then its not going to like what I write and try to turn it into some method/variable that exists. And if one is ever writing code when there's for example any kind of compilation error on a preceding line, or too few/many opening/closing braces, then the auto-completion tends to go mad in trying to change everything that one types into whatever it now thinks is acceptable.

Generally I'd love at least some preference options to control the autocompletion behaviour, so as to have it not autocomplete unless I actually more explicitly choose the autocompletion, i.e. get it working more like the default behaviour in other editors like Visual Studio / XCode. i.e. at the moment if I just type x = Method(), then just when typing the space or (, its liable to change x + Method into whatever it feels like, for example if I write exactly that right now in Xamarin Studio, what I get is: XmlSiteMapProvider = MethodCodeType().

At least, I haven't found any way with the current Xamarin Studio in which I can just type, without thinking x<space>=<space>Method() and not have it replace what I'm writing with other stuff if:

  • x or Method don't exist
  • or if its just confused (i.e. coz other code has some compile error, or because it's buggy as it appears to particularly be with the latest update)

Posts

  • mattwardmattward GBMember Xamurai

    Try turning on suggestion mode. From the Edit menu select Toggle Completion Suggestion Mode. When this mode is enabled it will prevent text from being completed unless you press the tab or enter key.

  • MichaelBevinMichaelBevin EEMember ✭✭

    Perfect. Thanks for that, that does the trick - I'd searched for something like that in the Preferences, but hadn't thought to look under the edit menu :).

  • CharlieFinlaysonCharlieFinlayson USUniversity ✭✭

    I think this option has been removed, from version 6.1.2 at least.

  • CharlieFinlaysonCharlieFinlayson USUniversity ✭✭

    Because it is now controlled under Preferences -> Text Editor -> Code Completion -> Complete with Space or Punctuation. Result!

Sign In or Register to comment.