Unable to deploy to iOS device due to multiple target architectures

ScionwestScionwest USMember ✭✭

I am trying to deploy a brand new Xamarin.Forms app to my iOS device (iPhone 6S Plus) and I'm not able to due to the following compiler error.

/Library/Frameworks/Mono.framework/External/xbuild/Xamarin/iOS/Xamarin.iOS.Common.targets: Error: Cannot specify more than 1 target architecture: 'ARMv6_ARMv7, ARMv7s, ARM64' (BokehApp.iOS)

This error is only present when I change the target configuration from simulator to my physical device.

I've attached the projects iOS Build settings for you to look at. What do I have configured wrong on the project?

Answers

  • ScionwestScionwest USMember ✭✭
    edited October 2015

    A quick update, still unable to get the app to run. I created a brand new project, followed the requirements in the Device Provisioning docs and tried to deploy a fresh project to my device. Had the same results.

    I have also just set the target architecture to ARM64 only, and still receive this compiler error. Continues to work fine any time I run through the simulator.

    If I run the app in Release configuration, as opposed to Debug, the app deploys to the device without any problems in my app solution + the empty project I created. It seems to just be an issue when trying to run through the debug configuration.

  • Rob_FrancisRob_Francis USMember ✭✭

    @scionwest did you ever solve this issue?

    I cant imagine it is still present but if it is, have you tried setting the build architecture to ARMv7 + ARM64.

Sign In or Register to comment.