iOS 10.1 Message: "App" May Slow Down Your iPhone

RodBarnesRodBarnes ✭✭USMember ✭✭
edited October 2016 in Xamarin.Forms

This morning, I was notified of some updates for Xamarin Studio -- I believe the updates were Xamarin.iOS 10.2.0.4 and Xamarin.Mac 2.10.0.105 -- but I didn't really notice the details; just remember the references to iOS and XS.

After the update, I attempted to build and deploy a previously successful app and it failed with an error indicating I needed to update Xcode -- so I did that, now Version 8.1 (8B62). App now builds and deploys successfully, but...

I am now getting an odd message on the iOS simulator -- see attached screenshot. The message only appears the first time any app is deployed and run. If I delete the app from the simulator and then deploy and run again, the message does not appear.

Not a big deal but it seems something ain't right with the latest updates in Xamarin.Forms?

Tagged:

Posts

  • JohnHJohnH ✭✭✭✭✭ GBMember ✭✭✭✭✭

    No, this is iOS showing you that message, you need to include 64 bit architecture in your build. If you search the forum you'll see this mentioned already.

  • RodBarnesRodBarnes ✭✭ USMember ✭✭
    edited October 2016

    Looking around, I found a setting Platform target under [project].iOS > Options > Build > Compiler and changed it from x86 to x64 and to Any CPU -- neither of which changed this behavior. Any new app, when first deployed and run, will present the message. What setting needs to be changed to address this?

    Very odd that the message only appears the first time the app is deployed and run and not on subsequent attempts.

  • RodBarnesRodBarnes ✭✭ USMember ✭✭
    edited October 2016

    @JoaoRutkoski -- thanks! That fixed it. I found this page 32/64 bit Platform Considerations where, under Enabling 64 Bit Builds of Xamarin.iOS Apps, it states (emphasis added): "NOTE: This section is included for historic reasons only and to help move older Xamarin.iOS projects to the modern APIs and 64 bits. All new Xamarin.iOS projects will use the Unified APIs and 64 bits by default."

    Clearly, this is not happening in the current XS version. Every newly created project requires going in and changing this setting.

  • Felix.xFelix.x ✭✭ USMember ✭✭

    @RodBarnes said:

    Clearly, this is not happening in the current XS version. Every newly created project requires going in and changing this setting.

    I think the document is talking about the iphone setting. I checked my project, the release/iphone setting is corrent. Only simulator configuration has this problem.

  • AmruthaTamanam.iosAmruthaTamanam.ios ✭✭ USMember ✭✭
    edited February 2017

    I changed the Supported Architectures under "Project Options > iOS Build" to i386 + x86_64 and setting Platform target under [project].iOS > Options > Build > Compiler and changed it from x86 to Any CPU and it worked for me.. :)

  • ChristianFalchChristianFalch ✭✭✭ NODeveloper Group Leader ✭✭✭

    You shouldn't need to change architectures when running on the Simulator - and new projects are already set up to use the correct architecture (avoiding the message the op mentions) when built for a device.

    You should be able to verify this by running a new project on the simulator and on a device.

Sign In or Register to comment.