Forum Xamarin Xamarin.iOS

Problems loading iOS solutions in Xamarin Studio on Mac

DanStephensDanStephens USMember
edited September 2016 in Xamarin.iOS

I am having issues opening/running iOS projects in Xamarin Studio. I have installed all of the available packages when I did the original installation and they all show when I go to "About Xamarin Studio Community" (see below). But when I go to open any demo solutions, the iOS, UWP, and WP8 projects are grayed out with a warning symbol that says "This project type requires Xamarin.iOS to be installed". Any help would be appreciated!

=== Xamarin Studio Community ===

Version 6.1.1 (build 15)
Installation UUID: 75216407-8d10-456c-a3f6-52b42cad7e92
Runtime:
Mono 4.6.1 (mono-4.6.0-branch-c8sr0/abb06f1) (64-bit)
GTK+ 2.24.23 (Raleigh theme)

Package version: 406010003

=== NuGet ===

Version: 3.4.3.0

=== Xamarin.Profiler ===

Not Installed

=== Apple Developer Tools ===

Xcode 6.3.2 (7718)
Build 6D2105

=== Xamarin.Mac ===

Version: 2.10.0.103 (Xamarin Studio Community)

=== Xamarin.iOS ===

Version: 10.0.1.8 (Xamarin Studio Community)
Hash: 3983064
Branch: cycle8-sr0-xi
Build date: 2016-09-23 15:34:54-0400

=== Xamarin.Android ===

Version: 7.0.0.18 (Xamarin Studio Community)
Android SDK: /Users/dan/Library/Developer/Xamarin/android-sdk-macosx
Supported Android versions:
6.0 (API level 23)

SDK Tools Version: 25.1.2
SDK Platform Tools Version: 24.0.0
SDK Build Tools Version: 23.0.2

Java SDK: /usr
java version "1.7.0_71"
Java(TM) SE Runtime Environment (build 1.7.0_71-b14)
Java HotSpot(TM) 64-Bit Server VM (build 24.71-b01, mixed mode)

Android Designer EPL code available here:
https://github.com/xamarin/AndroidDesigner.EPL

=== Xamarin Android Player ===

Version: 0.6.5
Location: /Applications/Xamarin Android Player.app

=== Build Information ===

Release ID: 601010015
Git revision: fa52f02641726146e2589ed86ec4097fbe101888
Build date: 2016-09-22 08:03:02-04
Xamarin addins: 75d65712af93d54dc39ae4c42b21dfa574859fd6
Build lane: monodevelop-lion-cycle8-sr0

=== Operating System ===

Mac OS X 10.11.6
Darwin Dans-MacBook-Pro.local 15.6.0 Darwin Kernel Version 15.6.0

Best Answer

Answers

  • JamieMellway.3392JamieMellway.3392 USMember
    edited October 2016

    Sorry, what was the fix? I updated to all the latest. That is, Xamarin Studio Community Version 6.1.1 (build 17), Xamarin.iOS Version: 10.2.0.4 (Xamarin Studio Community), and XCode 8.1. I now get this "This project type requires Xamarin.iOS to be installed" warning.

    Edit: Rebooting and then changing the Configuration Mappings from AppStore|iPhoneSimultator to AppStore|iPhone fixed it.

Sign In or Register to comment.