There is a blank space on the screen top on UWP 14393(Windows 10 1607)

huangjinshehuangjinshe USMember ✭✭✭

I was using 10586 before, All normal. But after I update to 14393, The top has a blank space. too ugly, because that is display on the Navigator(which display the App name). Is that a BUG or design?? Any one know? I upload the picture.

Best Answer

Answers

  • JohnHardmanJohnHardman GBUniversity mod
    edited October 2016

    @huangjinshe - That's interesting. I am getting the same thing (on phone, not desktop) - I assumed a change I had made had caused it but hadn't investigated yet. I guess it's not something I've done as you're getting it as well.

    Have you logged a bug in Bugzilla?

    My guess is that the change https://github.com/xamarin/Xamarin.Forms/pull/244 might have had an unintended effect.

  • huangjinshehuangjinshe USMember ✭✭✭

    @JohnHardman said:
    @huangjinshe - That's interesting. I am getting the same thing (on phone, not desktop) - I assumed a change I had made had caused it but hadn't investigated yet. I guess it's not something I've done as you're getting it as well.

    Have you logged a bug in Bugzilla?

    My guess is that the change https://github.com/xamarin/Xamarin.Forms/pull/244 might have had an unintended effect.

    No, I haven't logged a bug in Bugzilla yet.

    I really can't believe there are no developers not found it, because I already knew the problem long time ago. I even thinking there are only a few people using UWP under Xamarin.Forms.......

  • huangjinshehuangjinshe USMember ✭✭✭
    edited October 2016

    @JohnHardman said:
    @huangjinshe - See bug https://bugzilla.xamarin.com/show_bug.cgi?id=45835 . There is a workaround in the comments that resolves this problem for me.

    Thank you, actually it was me. Did you use some theme on your app? looks nice, could you recommend to me?

  • JohnHardmanJohnHardman GBUniversity mod

    @huangjinshe - No theme used. That particular page is a ListView making use of two DataTemplates, one for sub-headings (e.g. "USER PREFERENCES") and one for each of the options (which are basically two Labels and a hidden Button, filling the ViewCell).

    For the ViewCells using a hidden Button, it might be possible to get rid of the Button as a result of another UWP bug being fixed.

Sign In or Register to comment.