Failed to install app

Every time I run my ui test locally on a IOS 10 and 9.3 simulator I am getting the following exception;

Failed to install app /xx/xxx.app

ExitCode: 7
Unrecognized flag: xx/xx.app

install
    -u,--update-app <true-or-false> [OPTIONAL]  When true, will reinstall the app if the device contains an older version than the bundle specified DEFAULT=1
    -c,--codesign-identity  <codesign-identity> [OPTIONAL]  Identity used to codesign app bundle [device only]  DEFAULT=
    -a,--app-bundle <path/to/app-bundle.app>    Path .app bundle (for .ipas, unzip and look inside of 'Payload')
    -d,--device-id  <device-identifier> iOS Simulator GUID or 40-digit physical device ID

Env:
Xamarin.UITest 2.0.0
Xamarin.TestCloud.Agent 0.20.3
XCode 8.0
Xamarin IDE 6.1 (build 5441)

Before XCode 8.0 and Xamarin 6.1 everything worked fine.

Any help much appreciated.

Thanks

Stack Trace:

at Xamarin.UITest.iOS.iOSAppLauncher.LaunchAppLocal (Xamarin.UITest.Configuration.IiOSAppConfiguration appConfiguration, Xamarin.UITest.Shared.Http.HttpClient httpClient, System.Boolean clearAppData) [0x001fd] in :0
at Xamarin.UITest.iOS.iOSAppLauncher.LaunchApp (Xamarin.UITest.Configuration.IiOSAppConfiguration appConfiguration, Xamarin.UITest.Shared.Http.HttpClient httpClient, Xamarin.UITest.TestCloud.TestCloudiOSAppConfiguration testCloudAppConfiguration, Xamarin.UITest.Shared.Http.HttpClient testCloudWsClient, Xamarin.UITest.Shared.Http.HttpClient xtcServicesClient, System.Boolean testCloudUseDeviceAgent) [0x0007a] in :0
at Xamarin.UITest.iOS.iOSApp..ctor (Xamarin.UITest.Configuration.IiOSAppConfiguration appConfiguration) [0x00302] in :0
at Xamarin.UITest.Configuration.iOSAppConfigurator.StartApp (Xamarin.UITest.Configuration.AppDataMode appDataMode) [0x00017] in :0
at XXX.Setup () [0x000d5] in /xxxx/xx.cs:37

Posts

  • Glenn.WilsonGlenn.Wilson USXamarin Team Xamurai

    @ChristopherMyhill.2964 We have identified a bug that occurs when there is a space in the app path using AppBundle:
    ConfigureApp.iOS.AppBundle("path with/aspace/myapp.app")... that we are working on.

    Are you specifying an AppBundle with a path that has a space? If not, can you share your ConfigureApp statement?

  • ChristopherMyhill.2964ChristopherMyhill.2964 USUniversity ✭✭

    @Glenn.Wilson Thank you, that was exactly the problem I had. Removed the space and everything is back up and running.

  • Glenn.WilsonGlenn.Wilson USXamarin Team Xamurai

    @ChristopherMyhill.2964 Thanks for confirming. This is fixed in the latest dev build Xamarin.UITest 2.0.0-1524-dev build.

Sign In or Register to comment.