"Invalid device/simulator type.." Can't deploy to device!

DerekYoussiDerekYoussi USMember
edited September 2016 in Visual Studio

Can anybody please help? I have deadlines and i'm unable to run my project on a local device anymore!
Because of this I am unable to test my push notifications, which puts me in a very bad spot.

I can build and run on the simluator, but when I select a physical device, Visual Studio gives me the error:
"Invalid device/simulator type for Company.Mobile.Promoter.iOS project. Expected: iPhone."

I'm running the latest Xamarin 4.2.0.695 and Xamarin.iOS 10.0.0.1
I had to upgrade to VS 2015, so I just finished uninstalling/re-installing visual studio and xamarin. (This time xamarin installed via VS instead of external installer). Ever since then I am getting this error.
I've tried cleaning the solution, restarting VS, etc. But nothing seems to work

Answers

  • PubuduGayanPubuduGayan NZMember ✭✭✭

    @DerekYoussi I believe you have droid project as well. just go to droid project and untick the deployment plus select the iphone simulator in dropdown in project build option.

  • DerekYoussiDerekYoussi USMember
    edited September 2016

    Thanks for the Reply PubuduGayan.
    Yes I have a droid project also, they exist in the same solution, but in this case I am only building the iOS project, and the android is not set to build in the build configuration of the iOS project. I don't believe this is the issue. Also I am trying to deploy to physical devices not the simulator.

    After more testing, I found out that I can deploy to a physical iPhone device, but it's not working for either of my iPads (iPad mini 4, and iPad3). My application is an iPhone app (not a cross-platform app), but I still used to be able to deploy directly to the iPad, and it would just run in that compatibility mode where it allows you to zoom in.
    Did they remove this feature in a newer version of something?

  • PubuduGayanPubuduGayan NZMember ✭✭✭

    @DerekYoussi its happens to me in some stage. after i setup like that it worked for me. but your problem little bit strange. please post over here if you come a cross any solution.

  • kzukzu USXamarin Team, Insider Xamurai

    Hi @DerekYoussi, that's a weird one.

    Would you mind providing the logs via Help > Xamarin > Zip Logs... while connected to the Mac? (that brings the Mac logs too).

    /cc @joj

  • jojjoj USXamarin Team Xamurai

    Yes, this is a known issue with that release, since fixed. We did remove that functionality but it was unintentional. I'll look for a way to get you a patch @DerekYoussi to unblock you.

  • kzukzu USXamarin Team, Insider Xamurai

    Hi @DerekYoussi, I've put together a build on top of our current stable version that contains the fix for this issue. Please download it from http://xvs.xamarin.com/patcheddrops/Xamarin.VisualStudio_4.2.0.699.msi and give it a try.

    The contained fix will be available in future Xamarin releases.

    Thanks!

  • DerekYoussiDerekYoussi USMember
    edited October 2016

    @kzu I installed the patch you gave me, but i'm still getting the same error.
    Here are the zip logs you requested:

  • DerekYoussiDerekYoussi USMember
    edited October 2016

    @kzu and @joj , I updated my xamarin to the latest (4.2.0.703), and i'm still getting this same error!
    The mac is running latest xcode and OS X El Capitan version 10.11.6

    I attached updated zip logs

Sign In or Register to comment.