Unknown MSBuild failure. Please try building the project again on migrating classic APIs to Unified

MehulAgarwalMehulAgarwal USMember, University

Hi,
As a requirement from apple store to upload unified iOS app starting 1st Feb 2015. We have migrated our classic API app to unified following the steps(http://developer.xamarin.com/guides/cross-platform/macios/updating_ios_apps/) however when we tried to compile the migrated unified api application we are getting "Unknown MSBuild failure. Please try building the project again" .

we tried with new unified project as well though it gives same error "Unknown MSBuild failure. Please try building the project again".
I have attached screenshot for additional reference.

Any help on this would be highly appreciated.

Thanks.

Answers

  • MehulAgarwalMehulAgarwal USMember, University

    +Attachments

  • RolfBjarneKvingeRolfBjarneKvinge USXamarin Team Xamurai

    Can you attach the full build log?

  • MehulAgarwalMehulAgarwal USMember, University

    Attached application build logs.

  • MehulAgarwalMehulAgarwal USMember, University

    Attached application build logs.

  • PaulDistonPaulDiston USUniversity ✭✭✭✭

    Has there been any progress on this?

  • cvarelaecvarelae USMember ✭✭

    I have the same problem. I have not found the solution...

  • OtaMaresOtaMares DEMember ✭✭

    Any news here? Having the same issue too from time to time

  • WilliamJockuschWilliamJockusch USMember ✭✭
    edited April 2015

    Yes, getting this issue on my mac right now. Cleaning and rebuilding do not help. The error is happening in a PCL, before I get to any platform-specific code.

  • WilliamJockuschWilliamJockusch USMember ✭✭

    In my case, the problem was that the references were screwed up. When I tried to build in VS, I got much more appropriate errors, which pointed me to fixing the references. After that, it builds fine in both XS and VS.

  • TommyOvesenTommyOvesen USMember ✭✭

    Created a new, empty project. Got this error. Any news ?

  • TranTienDat.VnTranTienDat.Vn USMember ✭✭

    I have same problem. But i cannot build for all project (not PCL only).
    I tried to close solution and reopen it again.
    Now it is working. I hope it would help you !

  • RaviK.7922RaviK.7922 USMember

    I have faced the same problem. I overcame this issue by restarting system.

  • JonnazsJonnazs USMember

    Same. Created a new empty project. Got this error

  • XamarinDoctusXamarinDoctus COMember ✭✭

    Close and open again the IDE.

  • MARCOLERMAMARCOLERMA USMember
    edited September 2016

    I had a same problem with Xamarin.iOS, I fix that when I renamed the root folder.
    My project was cloned from Git and the name of the folder was written from the cloning with some characters like '%20' for space.

    Example: My%20First%20Project
    Solution: My First Project

  • NateVargheseNateVarghese USUniversity ✭✭

    This happens way too often. I would say after every 5 or 6 builds. Only solution i've found is to restart Xamarin Studio. Microsoft is really in there now.

    Version: 6.1 (build 5441)

  • DH_HA1DH_HA1 USMember ✭✭✭

    @NateVarghese I am seeing this too.. very annoying.. any workarounds?

  • NateVargheseNateVarghese USUniversity ✭✭

    @DH_HA1 Not a solution or a workaround but i just a hunch:

    Your not gonna like this one but i basically just try to keep all my UI stuff closed as much as possible. I'm pretty sure that issue only comes around when editing the XML files in Android. Perhaps its an issue on iOS UI files too. So i just open it, edit it and close it right away. Try to make all your changed at once too. It still gets me sometimes, but it's no longer every 10 minutes.

  • Sam.3816Sam.3816 USMember ✭✭

    I am seeing this more often than I used to as well, and when I dont get the message it simply does nothing and wont build until I restart xamarin. This is on a mac.

  • RonFreschiRonFreschi USUniversity ✭✭

    same problem as Sam.3816
    XS on Mac
    This time after droid project clean
    Only thing that's working is to stop-restart XS

  • OknirokOknirok USMember

    What a ridiculously bad way to report an error. "Unknown MSBuild error". Yeah, thanks for that insight Xamarin. There's some really horrible problems with the platform that need to be fixed--I can't believe people used to pay $800/year for this software.

  • I am facing same issue. XS community 6.1.1 on Mac 10.11.6
    Only way that worked so for is close -> restart either solution or IDE.
    This happened after updating to latest version of Android SDK and iOS 10.

  • RobinBruneelRobinBruneel USMember ✭✭
    edited October 2016

    Restarting my mac fixed it every time for this issue.

  • thealisakhithealisakhi AEMember ✭✭

    This error occurs when I make the change in the code, while the debug is running.

    To fix that I need to restart Xamarin.

  • GerhardSchreursGerhardSchreurs USMember ✭✭
    edited November 2016

    I have the same problem. "Unknown MSBuild failure" pops up on average after around 6 builds. Only solution for me is to restart Xamarin Studio. Interesting comment by "thealisakhi", I am also editing code frequently while a build is running. Maybe that has something to do with it...

    Xamarin Studio 6.1.1 (build 17)

  • knocteknocte GBMember ✭✭

    Has anyone reported the bug? I added my reproduction details in the one I found: https://bugzilla.xamarin.com/show_bug.cgi?id=29987

Sign In or Register to comment.