VS 2012 Publish Android Application menu option is disabled

Yesterday, I was able to create an Android apk package, and today, I cannot. I am trying to ship this new apk by end of the day, and this roadblock was a bit unexpected. I hate those "please someone help me right away" posts, but if someone has some insight here, it would be appreciated.

I'm running VS 2012 on a Win 8.1 PC.

After successfully creating an Android release package yesterday, I did do some reconfiguration this morning trying to upgrade my environment to support iOS 7 development from Visual Studio. (I don't know if that's a possible cause).

Now, the Tools - Publish Android Application menu is no longer enabled for my project.

I have my Build configuration set to Release, Platform = Any CPU, Linking Sdk and User Assemblies, Use Shared Runtime.

The app will compile fine, and I can deploy it directly to my test device and the app runs fine. But I can't create a proper apk file.

I've uninstalled and reinstalled all my Xamarin tools, and I'm now running Xamarin.Android 4.8.01013, and Xamarin.IOS 1.4.2 (although Visual Studio keeps prompting me to upgrade to Xamarin.IOS for Visual Studio 1.3).

I have a Business License which is in good standing. Heck, it worked fine yesterday.

Any insight is appreciated.

Thanks
-Bill

Posts

  • VijayReddyVijayReddy INMember

    Ignore this point if you already know it...

    "Select the Startup project if you have multiple in the same solution and check the menu."

  • I've also had to select the root of the Android project when in Release build.

  • I have made some progress on this issue. I have narrowed the problem done to: if I check "Use Shared Runtime" under Mono Android Options, then the Publish Android Application menu option is DISABLED. If I unselect Use Shared Runtime, then the menu option is ENABLED.

    Unfortunately, in testing of Deploying straight to device vs using an install package, my app seems to be dependent on the Shared Runtime component being installed, and the API Platform 14 framework. If these two components get installed in addition to my app, the app works, if they don't get installed, the app will freeze upon loading.

    These two components don't get installed (or deployed) if I uncheck Use Shared Runtime. They will get deployed when deploying directly to a device if I do check Use Shared Runtime.

    How to I get these components installed via an apk, when I apparently they are dependent on the Use Shared Runtime option and I cant create an apk when I select Use Shared Runtime?

  • @billspain did you made any progress on this issue. I have the same problem. A project which in release needs the check box "use shared runtime" checked otherwise will end to exceptions.

    It would be great if you could provide a solution if you found one.

    Cheers
    Mandy

  • billspainbillspain US ✭✭

    This was a while ago, so while I can't recall exactly what I did, I think I solved it by simply making sure that I have the Android application project selected in the Server Explorer.

    I don't know if this is related, by I also went through a stage where the application that I built would run fine on a Nexus 10 tablet, but would fail to run on a Samsung Galaxy Tab 10. This problem was related to a bug impacting Android devices with Intel processors, which has since been resolved by Xamarin.

    Currently my app builds and runs fine. Sorry that I can't provide much more detail on that specific problem. I know I should have posted a solution last September, but I got too wrapped up in the deadlines of getting the application deployed and moving onto the next project...

    -Bill

  • I also had a similar problem. Mine got fixed when I unchecked the "Use Shared Runtime" option in the build options window that can be found in the project properties.

  • AliceWaddicorAliceWaddicor USMember

    Selecting any file in the Android project in Solution Explorer seemed to fix the issue for me

  • ThomasFlemmingThomasFlemming DEMember ✭✭

    @PaulMutie.8934 said:
    I also had a similar problem. Mine got fixed when I unchecked the "Use Shared Runtime" option in the build options window that can be found in the project properties.

    you saved my day :-)

  • i also check this but still publish android app is disabled

  • unlikely, BUT the answer for me:

    @AliceWaddicor said:
    Selecting any file in the Android project in Solution Explorer seemed to fix the issue for me

Sign In or Register to comment.