Forum Visual Studio

Unsupported major.minor version 52.0

Hello! When you create a project , an error occurs Android Unsupported major.minor version 52.0. What to do? Thank you!image



  • MarkusStoebeMarkusStoebe USMember ✭✭

    Same Problem here after I added xamarin.maps from NuGet to my project. It compiles and runs fine on iOS but Android is a huge problem. Fails to build with no obvious reasons...

  • AllisonTaylorAllisonTaylor USUniversity

    I concur with Markus, with a twist...I did not have API level 24 preview installed, but I did have API 24 Build Tools, which was not from the preview channel. Things worked only after I removed API 24 Build Tools.

  • KenYeeKenYee USMember ✭✭
    edited June 2016

    This really needs to be fixed...some of us really do work w/ Android Studio and other projects instead of Xamarin Studio :-P

    Has anyone reported this bug yet?

    p.s., this also affects Xamarin Studio on OSX. Isn't just a Visual Studio plugin issue....

  • JepcabJepcab PHMember

    Uninstalling Android N (API 24) , rebuilt and voila...... did the trick for me

  • 15mgm1515mgm15 USMember ✭✭✭✭

    Thanks for the solution! @MarkusStoebe

  • KeatKeanLeeKeatKeanLee USMember

    @AllisonTaylor said:
    I concur with Markus, with a twist...I did not have API level 24 preview installed, but I did have API 24 Build Tools, which was not from the preview channel. Things worked only after I removed API 24 Build Tools.

    Yeah....need to remove API24 Build Tools as well.....

  • tarikultarikul AUMember

    @AllisonTaylor It fixed my issue too! Had to remove API level 24 and Build tools 24 both!

  • austindominicaustindominic USMember
    edited August 2016

    Install JDK 1.8 in mac it would work fine
    Some times update does not work in mac so check your jdk version by using terminal and checking javac -version if javac 1.7 update JDK manually

  • merbsmerbs PHMember ✭✭

    thank you so much worked for me :)

  • EnAldemitaEnAldemita USMember

    Thanks markus it works

  • renandantonrenandanton BRMember

    It's work for me, when i removed API 24 Build Tools.

  • No need to remove anything. Go to visual studio and change inside project properties SDK version and that all.

  • iManchaiMancha ZAMember ✭✭

    @tohwei lol at "just like area 51 ! Crazy."

    I like the way you provide a detailed solution. You should start your own blog just for the latest Xamarin bugs and their solutions.

  • OMG Thank you for the solution!!! I've been stuck with debugging the blank apps for week.

  • tohweitohwei USMember ✭✭

    Thanks for the comment.

    Btw, here's my blog

  • DanielArayaDanielAraya DEMember ✭✭

    In my case (Windows, Java SDK 1.8) I had to update proguard (manually) to fix this issue.
    See this thread for a how-to:

  • FernandoOttFernandoOtt USMember

    @MarkusStoebe said:
    holy moly, I think I found a solution: looks like the preview sdks for api-level 24 were the problem. Open the Android-SDK-Manager an deinstall everything from the preview-channels, after that clean all, rebuild all...worked for me.

    This solve the problem for me. Tks!

  • JesKirkupJesKirkup GBUniversity

    To be fair Jevgenij Kononov already gave the correct solution to this on August 30th which also by the way keeps things up to date with the latest and greatest :-). No need to downgrade any Android 7 SDK's just reference the new 64 bit version of JDK 1.8 rather than the old 32 bit version of JDK 1.7

    "Go to visual studio and change inside project properties SDK version and that all."

  • mubimubi USMember ✭✭✭

    Delete Build tools 23.x (all versions of 24)
    Delete API level 24 also from Android SDK Manager
    It worked for me.

  • MiguelCervantesMiguelCervantes MXMember ✭✭✭

    @ireshika thanks for the answer! that worked for me! without having to uninstall API Level 24 stuff, just updated the JDK to 1.8, clean/rebuild app and everything worked!

  • @ireshika said:
    download android JDK1.8 from below location
    And in Preferences->SDK Locations ->Android change your JDK path to JDK 1.8
    This is a version miss match that your compiler is looking for java version 8 and you have java version 7.If you have installed Android studio make sure to set JDK paths separately and if you are installing Android studio after installing tamarin studio ,make sure it doesn't override your JDK version


  • EdvaldoSilvaEdvaldoSilva USMember


    Change the Java SDK to 1.8.x.
    After restarting Visual Studio, run "Clean Solution", "Build" and be happy!

  • sanwalsanwal DEMember

    I have upgraded to jdk 1.8 and still i cannot see any icon of the application on emulator.

  • AnubhavRanjanAnubhavRanjan INXamarin Team Xamurai

    @sanwal can you please elaborate and provide more information on the issue you are facing?

  • AlanClarkAlanClark USMember ✭✭✭

    @sanwal It might be worthwhile checking your adb logcat to see if that shows any information about what's going on with the device:

  • rughvi8784rughvi8784 GBMember ✭✭

    Installing jdk 1.8 and changing the JDK path in VS2015 has fixed the below issues

    1. android layout designer
    2. unsupported java major / minor version 52.0


  • ItaloPessoaItaloPessoa BRMember ✭✭

    Install jdk 8 and delete /bin and /obj as @hvaughan said, worked for me. Thanks

  • SebastianKruseSebastianKruse USMember ✭✭✭

    Same problem here with Build-Tools 25. Removed it and everything comes back to work.

  • SimonWainwrightSimonWainwright GBMember ✭✭

    Installing JDK 8 and setting my Visual Studio Android Settings to point to it worked for me

  • aw230012aw230012 USMember ✭✭

    It seems every time I upgrade Xamarin something like this happens. It takes minutes to install and hours to fix, it's becoming ridiculous.

  • CullenJCullenJ USMember ✭✭
    edited March 2018

    I'm just here saying this is still not working in March of 2018 after the most recent Xamarin update. I've tried switching JDK paths, removing old build tools, manually updating proguard, updating the NDK, changing the JAVA_HOME variable, and rebooting all the things. Nothing works. I just want to get back to doing what my job's supposed to be. Not fixing the tools. Xamarin is so incredibly frustrating to use when every update introduces batches of regression Xamarin issues.

  • CullenJCullenJ USMember ✭✭

    Turns out venting helped. I got it working. I don't really know how. It was a combination of redoing all of the above things. Eventually it worked. Wish there was a better explanation as to what the issue was and why the above fixes it, but thought I'd share for the others who are still fighting this.

  • masahikomiyasakamasahikomiyasaka JPMember ✭✭

    I encountered this after upgrading VS2017 to 15.6.0.
    I didn't fix it yet, I'll report the result of trying the above things as CullenJ said.

Sign In or Register to comment.