An exception was thrown ... "NuGet.PackageManagement.VisualStudio.VSSolutionManager"

Hello,

since updating to the all new and "stable" XamarinVS 4.2.0, Cycle 8, Visual Studio greets me with


Microsoft Visual Studio

Operation failed

An exception was thrown while initializing part "NuGet.PackageManagement.VisualStudio.VSSolutionManager".

GetFullVsVersionString must be called on the UI thread.

OK

After that, all components are marked as "incomplete". Needless to say, that compiling fails, too. This happens whenever I am opening a Xamarin.Android project using the usual Android Support Library components. Also, the same message appears whenever I try to open the NuGet Package Manager Console.

My Visual Studio version is

Microsoft Visual Studio Community 2015
Version 14.0.25425.01 Update 3
Microsoft .NET Framework
Version 4.6.01038

If I close Visual Studio and restart it with a plain old Windows .NET project with NuGet components everything works fine. But as soon as I open a Xamarin.Android project the message appears again and again.

Anybody got a cure or work-around for this, except downgrading to the previous Xamarin release?

Posts

  • JimTyminskiJimTyminski USUniversity ✭✭
    edited September 2016

    I simply get this error:
    Severity Code Description Project File Line Suppression State
    Error **One or more errors occurred. App1.iOS **

  • MBondarenkoMBondarenko UAMember ✭✭
    edited September 2016

    I found temporary solution.

  • [Confirmation] @NikitaBondarenko Thanks the work around you mentioned worked for me as well, until someone comes up with the solid solution.

  • ChristianGillChristianGill DEMember ✭✭

    Confirm. Had the same problem in Visual Studio 2015.
    After updating to the next stable version i got the same error.
    Components in the project had the status incomplete and i couldnt build anymore :-(

    Solution was.
    1.) Close Visual Studio
    2.) Open it again.
    3.) Go to Extras -> NuGetPacket Manager ->PaketManagerSettings
    4.) Click o.k.

    And now i can load the project again ...

    These Bugs are really nasty. I searched two hours ... This should not occur after updating to a stable version!

  • SageMossSageMoss USMember

    ChristianGill's answer worked for me.

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    In case it might be useful for other releases in the future, this issue was listed as a known issue in 3 places related to the release that can be useful to check if you hit issues after updating:

    (The issue was recorded there as of September 14 06:49 UTC, and various possible workarounds have been recorded and updated there as of September 15 0:21 UTC (a little while after the second comment on this forum thread).)

Sign In or Register to comment.