Forum Xamarin.iOS
We are excited to announce that the Xamarin Forums are moving to the new Microsoft Q&A experience. Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

We encourage you to head over to Microsoft Q&A for .NET for posting new questions and get involved today.

No Resource files found

Simon.5621Simon.5621 USMember ✭✭

I updated to the newest versions of XCode and Xamarin for Visual Studio yesterday. I tried to compile and deploy our app after that.

The Android project is working fine.

On iOS no Resource files are found:

new UIImageView(new UIImage("image.png"));

all throw an error cause the file seems to be missing. Also the app icon is gone and the app is shown with the standard icon.

Everything was working fine before, tho i'm not 100 % sure no changes have been made since the last successful deploy. . All resource files have the BundleResource BuildAction. The built app also has the same size as before, so i guess the files are packed and available but can't get found for another reason.

I'd appreciate any help. If you need further informations, please just ask.



  • Simon.5621Simon.5621 USMember ✭✭

    Clearing the obj and bin folders solved the issue.

  • RogerSchmidlinRogerSchmidlin CHUniversity ✭✭✭

    I created a new solution. And I don't have any of the resources created for me in iOS. Icons were generated for Android. I just updated to the newest and greatest versions of Xamarin. Any ideas why those images are not created?

Sign In or Register to comment.