Forum General

Is it possible to use previous version of Xamarin Studios?

MikaKorhonenMikaKorhonen FIMember

I updated my xamarin studio today, which was a horrible mistake.
Now I cannot debug no more until app I'm developing crashes.
I am pretty sure this is caused by the update because I cannot recognize any changes in my code before and after update.
This is an error code from my application output:

[] * Assertion at /Users/builder/data/lanes/monodroid-mlion-monodroid-4.8.0-branch/3f1c339b/source/mono/mono/mini/mini.c:3806, condition `l' not met
[mono-rt] Stacktrace:
[mono-rt]   at <unknown> <0xffffffff>
[mono-rt]   at *****.OnStart () [0x0005b] in */******/****:391
[mono-rt]   at Android.App.Activity.n_OnStart (intptr,intptr) [0x00008] in /Users/builder/data/lanes/monodroid-mlion-monodroid-4.8.0-branch/3f1c339b/source/monodroid/src/Mono.Android/platforms/android-16/src/generated/Android.App.Activity.cs:3488
[mono-rt]   at (wrapper dynamic-method) object.bdd34d4d-25c6-43d0-872e-aef57e05c00b (intptr,intptr) <IL 0x00011, 0x0003b>
[mono-rt]   at (wrapper native-to-managed) object.bdd34d4d-25c6-43d0-872e-aef57e05c00b (intptr,intptr) <IL 0x00022, 0xffffffff>
[mono-rt] =================================================================
[mono-rt] Got a SIGSEGV while executing native code. This usually indicates
[mono-rt] a fatal error in the mono runtime or one of the native libraries 
[mono-rt] used by your application.
[mono-rt] =================================================================

I censored part of the text with stars.

And in my code at line 391 there is only if statement

    if(1 == bluetoothService.GetState() || 0 == bluetoothService.GetState())


  • MikaKorhonenMikaKorhonen FIMember

    What is causing this SIGSEV ? Application runs perfectly right when Releasing, but Debug don't work at all.

    If you have any idea how to fix this or how to run previous version of xamarin studios I might be pleased.

  • serhataydinserhataydin USMember

    I also have the same problem! It's really annoying..

  • RichardKershawRichardKershaw GBBeta ✭✭

    Yes ... us too!

  • BenjaminRogersBenjaminRogers USMember

    Just noticed this post. Looks suspiciously similar to an error I just posted in the Android forum:

    That said, I'm seeing failures in both Debug and Release builds.

  • MikaKorhonenMikaKorhonen FIMember
    edited July 2013

    Ok. I managed to install Xamarin studio version 4.0.9 instead of 4.0.10. That didn't solve the problem. If anyone wonders how I did it :

    -At Xamarin Studios click "Help" -> "Check for Updates"

    -Change "Update channel" from "stable" to "beta" or "alpha" (I searched from Beta)

    -Found installation files for "Xamarin Studio 4.0.9"

    -Hit "Restart and Install Update"-button

    That still didn't solve my problem.

    I wish ppl at xamarin fixes this bug asap... Untill that, I must keep continue to "debug" with


  • serhataydinserhataydin USMember
    edited July 2013

    As i learned from Xamarin, it's possible to download old versions from account page..

  • MikaKorhonenMikaKorhonen FIMember
    edited July 2013

    serhataydin: Thank you, I'm going to try that out.

    Yes you can download older version, but it won't install cause I have Newer version. Oh my... Seems like I need to uninstall Xamarin Studios and then try to install that older version.

  • serhataydinserhataydin USMember

    I downloaded the older version of Xamarin Android (4.6.8) and installed it, the problem has been gone..

  • serhataydinserhataydin USMember
    edited July 2013

    Yo don't need to reinstall Xamarin Studio. Just install 4.6.8, it will downgrade..

  • MikaKorhonenMikaKorhonen FIMember

    It didn't work so well... Still getting the same error while trying to downgrade...

    InComatible version of Xamarin.Shell detected.
    Version of Xamarin.Shell on the system is newer than the one supported by Xamarin.Android 4.6.08007. Please download the latest version of Xamarin.Android 4.6.08007 from Xamarin website and try again. If the issue presist, please contact [email protected]
  • serhataydinserhataydin USMember

    Do you use Mac or Windows?

  • MikaKorhonenMikaKorhonen FIMember
    edited July 2013

    I use windows. I have tried to uninstall whole program. And reinstall with "mono-android-4.6.08007.msi"

    .msi file I mentioned earlier keeps saying same error I posted above. XamarinInstaller I recently donwloaded from xamarin sites seems not to install XamarinStudio.

    XamarinInstaller worked finally. But instead of 4.6.8 Xamarin Studio still seems to be 4.0.10 (build 7).

  • MikaKorhonenMikaKorhonen FIMember

    Ok. I'll give up on trying. I am just wasting my time if I continue on trying. Lets just wait when they manage to produce their next stabile update which may let me continue my work. I try using Visualstudio then.

  • amilleramiller USXamarin Team Xamurai

    Hi @MikaKorhonen!

    The "Incompatible version of Xamarin.Shell detected" error should be resolved by uninstalling the software through "Add and Remove Programs". However, my guess is that the msi files you are re-installing are somehow still causing the issue. If you could write into [email protected] I can send you the files you need to get everything working again :) Thanks!

  • MikaKorhonenMikaKorhonen FIMember

    I recently took a customer support with xamarin. Have to say that you solved my problems. To solve this I had to remove Xamarin Android and Xamarin IOS from commandpanel->add/remove software.

    So thank you Team Xamarin. Now I can continue my work :)

  • JesseChangJesseChang USMember

    Thank you for opening this thread and sharing the solution. I too have problem after upgrading, however, mine is really strange. After I upgrade, all of my apps(without any code changed) will suddenly die after launching. Checking android log says the activity manager facing unexpected fatal error and my main activity has died. I spent a day couldn't fix until I read this post and downgrade back to 4.6.8. Now everything is fine as before.

    Thanks again for this thread and look forward to seeing Xamarin releasing any fix.

  • MikaKorhonenMikaKorhonen FIMember

    JesseChang, You're welcome. :)

  • moljacmoljac HRBeta ✭✭✭

    This bug is fixed in 4.8.1

    Just to report it is fixed in 4.8.1.

    I had similar behaviour in SharpSerializer port

Sign In or Register to comment.