Latest stable Studio crashing and won't open my solution

BrettNagyBrettNagy USMember, Beta

Several issues this morning:

Installed latest stable (4.0.10 (build 7)
Xamarin.iOS 6.4.0.2

When Studio launches it tells me Xamarin.Mac is missing. I've never installed this and don't want it.
The "Recent Solutions" listing shows old solutions.
When I File->Open, Studio crashes
When I double click the solution I was working on yesterday, Studio says "Cannot Open Xamarin Studio format files" and then crashes.

I need to work today. What can I do?

Posts

  • CameronFulfordCameronFulford CAMember

    Same thing here, can I revert until it is fixed?

  • TeamTSICorpTeamTSICorp USMember

    same here. just saw an update on xam studio.. updated... and now it complains at startup. Did this release even go through testing ????

  • BrettNagyBrettNagy USMember, Beta

    Wow - this is horrible. I don't think this update was meant for stable release, if release at all.

    I moved my Studio application bundle out of the Applications directory and clean installed. Back to 4.0.9 and everything working again.

  • DannyCDannyC US ✭✭✭✭

    Having same exact problem. Even the Mono Framework MDK 3.2.0 fails, it downloads but does nothing upon clicking "Restart and Install Update".

  • AlanMcGovernAlanMcGovern USXamarin Team Xamurai

    Can people experiencing the MonoMac/Xamarin.Mac issue please send me ([email protected]) their log files (click Help -> Open Log Directory). We're trying to track this down but no-one has been able to reproduce the issue as of yet.

  • AlanMcGovernAlanMcGovern USXamarin Team Xamurai

    Things to try:
    1) Let me know if you installed third party extensions like F# support
    2) Make a copy of and then delete the directory ~/Library/Caches/XamarinStudio-4.0/addin-db-001

    If that fixes the issue for you then send me that directory zipped up.

  • DannyCDannyC US ✭✭✭✭

    @AlanMcGovern emailing you right now.

  • AlanMcGovernAlanMcGovern USXamarin Team Xamurai

    Also could people running into this issue run these two commands in a terminal and let us know the output:

    $ mono --version

    $ ls -la /Library/Frameworks/Mono.framework/Versions/

    One set of logs indicates the user has Mono 2.10.12 installed, which is too old. They should have been upgraded to 3.x as part of update set which provided Xamarin Studio 4.0.10.

  • DannyCDannyC US ✭✭✭✭

    The mono framework update downloads but won't install. Hitting restart and install does nothing.

  • DannyCDannyC US ✭✭✭✭

    For those having issues, try downloading the latest mono framework file and installing. I was having problems since the latest Stable channel Xamarin Studio update was missing the latest mono framework.

    download.mono-project.com/archive/3.2.0/macos-10-x86/MonoFramework-MRE-3.2.0.macos10.xamarin.x86.pkg

    Thanks for all the help @AlanMcGovern !

  • PJBeamanXPJBeamanX USXamarin Team Xamurai
    edited July 2013

    @DannyC: Thanks for providing information to Alan!

    One small change - for most users, the MDK is preferred over the MRE. Here's that link: http://download.mono-project.com/archive/3.2.0/macos-10-x86/MonoFramework-MDK-3.2.0.macos10.xamarin.x86.pkg

Sign In or Register to comment.