Xamarin Studio not starting in Windows 10 Pro

SmartmanAppsSmartmanApps AUMember ✭✭✭

Hi all,

I have just installed Visual Studio Community 2015 and Xamarin Studio for Windows. I know they are encouraging people to use Visual Studio now, however I will be working on a project with someone who is on a Mac, and I have seen posts saying that there are issues when switching between the 2 products, plus in the Udemy course I am doing, the instructor is using XS, so I would much prefer to get XS working if possible (easier to follow the video, and less likely to have issues with my collaborator).

When I start XS, I get a clock for a few seconds, then nothing. I have found it running as a background process (rather than as an app) in task manager - obviously that is incorrect. I have seen mention of similar issues involving .NET version (saying that 4.0 not sufficient, must have 4.5), and I THINK this may be the problem - see attached picture showing Windows says I'm running 4.6, but XS log says I am running 4.0. None of the solutions I have seen for similar issues have worked yet.

Does anyone have a solution for this? If not maybe I should look at trying an older version - what is the latest version that people are using on Windows here?

thanks,
Donald.

Best Answer

Answers

  • JohnHJohnH GBMember ✭✭✭✭✭

    Just to be aware, you cannot compile iOS apps in Xamarin Studio on Windows, you have to use Visual Studio (paired with a mac), or Xamarin Studio on the mac itself. I dont know what the issue is that you have described, but if this is what you are trying to achieve then those are your options.
    Also, I switch between Xamarin Studio on my mac and Visual Studio every once in a while. I dont know what issues you are referring to (I dont use the designers so maybe those?) but its pretty streamlined.

  • SmartmanAppsSmartmanApps AUMember ✭✭✭

    Yes, I am aware that - what I need is a fix for the problem. I have seen comments (when looking around for a solution) from people saying there are problems between XS and VS when you're switching between them.

  • DaveHuntDaveHunt USMember ✭✭✭✭✭

    I'm afraid you're chasing a red herring there. The runtime version and framework versions are different things. I don't know what's causing your problem, but I'm fairly certain it isn't a .NET version issue.

    If you want to try an older version, I would suggest 5.10.3, though I don't know if it will work any better for you than the 6.x version.

    With regard to your colleague working on a Mac, unless you are creating an Android app, you won't be able to do anything with XS on Windows. No building/testing for anything other than Android apps.

  • MarcDeveauxMarcDeveaux USMember
    edited August 2016 Accepted Answer

    had same problem, after I download GTK# 2.12.30 it worked (then immediately upgraded to 2.12.38)

    https://store.xamarin.com/account/my/subscription/downloads#cycle6
    Get the latest stable version of Cycle 6 here.

    Xamarin Studio was running in the background but not displaying a window, killed 4 of them

  • SmartmanAppsSmartmanApps AUMember ✭✭✭
    edited August 2016

    @MarcDeveaux said:
    had same problem, after I download GTK# 2.12.30 it worked (then immediately upgraded to 2.12.38)

    Woo hoo! Thank you Marc! That fixed it. :-) When I was installing, it said the required version was 2.12.22, but clearly it's 2.12.30.

Sign In or Register to comment.