Forum Xamarin.iOS

iOS app fails Apple app review when using location services

DanKuncDanKunc USMember

Hello all,

I have built a navigation based app for iOS using Xamarin. The app works well on my device (iPhone 5S running iOS 8.4), and every device I've tested it on. However, when I submit it to the Apple app review process, they claim that the app fails when it starts using their location. They say that upon opening the app and being prompted to allow the app to use their location, that the app crashes, whereas if they don't give it permission, it keeps running. Likewise, if they don't give it permission, go into the device settings, and give it permission, once they come to the app again, it crashes. They say the device they're using is an iPhone 6 running iOS 8.4. I tested it on a physical device just like that, and it ran with no problems.

I do believe I have the correct items added to my info.plist and request the correct permissions, because it runs just fine on my devices.

Another thing of note is that this device doesn't generate a crash log, nor does Xamarin Insights catch it. I have no idea why this is happening, and so I'm really hoping that someone else here has experience dealing with this type of issue, and that they can provide some help.

Thank you very much.

Answers

  • BrandonFryeBrandonFrye USMember

    We are running in to this EXACT same problem - any resolution?

  • DanKuncDanKunc USMember

    I did resolve it, but unfortunately it was over a year and I don't remember exactly what I did. I remember a part of it was that my CLLocationManager was not being used as a singleton, I had a bunch of different instances of it in the various views and whatnot. That would be the first thing I would check. Can you check yours and see if you have a singleton model, or if you're using multiple CLLocationManagers?

Sign In or Register to comment.