Forum General

Alpha Release: Cycle 8 Feature Release Preview



  • SummerStoneSummerStone ROMember

    Great work

  • AdrianKnightAdrianKnight USMember ✭✭✭✭

    @BrendanZagaeski Android Support packages are an absolute nightmare with Preview 2 and 3 (I'm using VS 2015 with Update 3). In the release notes for Alpha Preview 3, I have seen several bugs that mention support packages, but I created a bug yesterday:

    Sadly, my Internet connection is very slow, so downloading 200MBs (for r_29 repository) each time is very time-consuming.

    Another problem I have is I'm prompted to connect to the Mac Host every time I close and open Visual Studio for the same project. Seems like VS can't remember my credentials and connect automatically.

  • TomPeerTomPeer USMember ✭✭

    The installer from Xamarin.VisualStudio_4.2.0.378 tried to install "Xamarin.Forms.Templates.vsix" also if all Visual Studio Installations was deselected.

  • JordanMaxJordanMax USMember ✭✭

    @Alejandrolvarez said:
    Hi all,

    There's an error in the iOS Simulator (for Windows) guide. It says that both Xamarin for Visual Studio and the networked Mac for Xamarin.iOS should be running the Beta channel.

    However, if i've understood properly, this feature is only compatible with Visual Studio for Xamarin, i.e. Cycle 8 in Alpa channel. Am I right? Besides, is it necessary to move Xamain.iOS to Beta channel, too?

    I am very surprised nobody addressed this issue? I am currently asking the same thing. Also, seems to some problems with the iOS simulator on Windows, it's completely blank for me even though it works fine when building to mac simulator. The windows one is just black and doesn't load the app/phone.

  • JordanMaxJordanMax USMember ✭✭

    @DanSiegel said:
    I had a similar issue as @AdrianKnight, I'm on Windows 10 Pro. When I double clicked the installer it didn't seem to do anything. Whatever the issue remoting never worked for me, and when Visual Studio "deployed" my app, it seemed to deploy to that spot where missing socks go since the app never showed up on either the simulator on the Mac or my iOS device even though Visual Studio swore it was deployed and running.

    Another comment nobody from Xamarin seemed to address. This is a pretty big issue I would imagine. When I downloaded the preview simulator, it took about 5 seconds and then just disappeared. If I try to go to the folder and run the .exe, nothing happens at all. When I try to build to ios remote simulator the simulator opens with a complete black screen.

  • TomPeerTomPeer USMember ✭✭

    @TomPeer said:
    The installer from Xamarin.VisualStudio_4.2.0.378 tried to install "Xamarin.Forms.Templates.vsix" also if all Visual Studio Installations was deselected.

    Same with .413:

    Error 1721. There is a problem with this Windows Installer package. A program required for this install to complete could not be run. Contact your support personnel or package vendor. Action: vim05B6617BB9C22AE26F480B3E85D256EB, location: , command: /q "C:\Program Files (x86)\Common Files\Microsoft Shared\Xamarin\Xamarin.Forms.Templates.vsix" /admin

    All Visual Studio installations were unselected (I prefer Xamarin Studio).

  • Josu_brJosu_br USMember ✭✭

    I don't know if this release is really the problem but after update to the last version of xamarin alpha, font awesome doesn't work anymore on IOS only in Android, anyone else with the same problem?

  • Josu_brJosu_br USMember ✭✭

    My bad, I forgot to set FontFamily = "fontawesome"... sorry.

  • NealCulinerNealCuliner USBeta ✭✭✭

    FYI only, I did a FETCH from version control area and the Fetching... message remained in the top bar for the remainder of the app session, never cleared. Also would like a prune option on that fetch by the way.

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    This thread has now been closed to direct further updates about this release onto the latest announcement:

This discussion has been closed.