Forum Visual Studio

I can no longer debug on Xamarin for Visual Studio 2015

I recently had to wipe my entire PC due to getting too many Blue Screens, so after that I went through the process of reinstalling all my software development tools, in this case Visual Studio Community 2015 and Xamarin for Android.

It went smoothly enough but I now have a new problem, when I debug the Project I am working on, breakpoints never get hit. I tried cleaning the solution, restarting the PC/Android tablet, reinstalling Xamarin and changing devices, but my breakpoints never get hit when I'm debugging my app, and its pretty annoying to say the least.

Before I did the hard reset on my PC, everything worked perfectly.

I would switch to Xamarin Studio but it seems since Microsoft took over Xamarin they have dropped the Windows version of Xamarin studio, so I am now stuck with Visual Studio with a broken debugger.

I think this is a Xamarin related issue because when I use Visual Studio to work on web applications, the debugger works as expected.

Is there anyone who has the latest version of Xamarin for Visual Studio experienced the same problem? and if so, what did you do to get the debugger working again?

thank you, I'll be happy to provide technical/build information if you need it.

Best Answer

Answers

  • washburn_itwashburn_it ITMember ✭✭

    Hi,
    I had the same issue so I was told to check in the Project Properties the current debugger selected (you can find it in one of the pages).
    I had the one from Microsoft so I switched to "Xamarin", closed Visual Studio, reopened and it started working.
    I hope it may be useful, regards.

    Roberto

Sign In or Register to comment.