Can start app on emulator but not on device (WinPhone)

Hello,

I'm developing a cross-platform app (iOS, Android, WinPhone) using Xamarin.Forms Shared in Visual Studio 2015 Pro.

I have a problem:

When i try to start my app in WinPhone emulator, it's all ok, but when i try to start it in my WinPhone device, i cannot, because Visual Studio said that i must deploy first.

So, i tried to deploy my app (Build -> Deploy), but i can't. I received this error: "DEP6701 : Bootstrapping failed with unexpected error: '0x88002000 ' ".
I tried to clean, rebuild, restart Visual Studio, Reboot PC and do other things... Nothing helped me...
Howewer, then, i not received that error, but another:
"Severity Code Description Project File Line Suppression State Error Error : DEP0001 : Unexpected Error: Exception from HRESULT: 0x8103010D".

App is not installed on device, the WinPhone project is set as StartUp Project, in solution "Properties" is checked "Build" and "Deploy" in WinPhone Project...

Any help would be great,

Thanks

Best Answer

Answers

  • FredyWengerFredyWenger CHInsider ✭✭✭✭✭

    @Volodymyr_Leskiv
    Have to registered your phone as "development phone"?
    If not, that can be the problem maybe...

  • Volodymyr_LeskivVolodymyr_Leskiv USMember ✭✭

    @FredyWenger thanks for your reply.
    I already resolved this problem some days ago with some clean and build :neutral:

  • MarcinBogielMarcinBogiel USMember ✭✭

    I have the same problem. Every single time when I try to deploy my solution I get message:

    "Severity Code Description Project File Line Suppression State
    Error DEP0001 : Unexpected Error: -1988945906 my_project_name.WinPhone "

    @Volodymyr_Leskiv, I cleaned(Build->Clean solution) and then built(Build->Build solution) as you mentioned above, but I still can't Deploy my solution. Could you tell me exactly what you did to fix it?

  • RubenAntonioRubenAntonio USMember ✭✭

    thanks bro, this solved my problem

    @MarcinBogiel said:
    Ok, I found out how to fix my problem. :) I can't edit my entry above so I am writing a new one.

    In my case, the problem was "Windows Phone IP Over USB Transport(IpOverUsbSvc)" service which needed to be running. There is a great video tutorial on YouTube how to run it:

    Then I closed my Visual Studio and opened it again. After that, I was able to deploy my solution and run my App on my phone. :)

    Remeber, every time when run your computer that service isn't working and you have to enable it manually.

  • clamumclamum USMember
    edited July 2016

    @MarcinBogiel said:
    I have the same problem. Every single time when I try to deploy my solution I get message:

    "Severity Code Description Project File Line Suppression State
    Error DEP0001 : Unexpected Error: -1988945906 my_project_name.WinPhone "

    @Volodymyr_Leskiv, I cleaned(Build->Clean solution) and then built(Build->Build solution) as you mentioned above, but I still can't Deploy my solution. Could you tell me exactly what you did to fix it?

    I'm getting this too trying to debug my Xamarin.Forms WinPhone project, though I don't think I've seen it before. I did upgrade to Xamarin.Forms v2.3.0.107 last night though (which was hellacious in itself until I found a post explaining package dependencies between XF and Android.Support.v4 packages. Guess I can't update both).

    Any ideas? I was going to use Xamarin.Forms for an app my friend's company wants made but I'm having second thoughts. It just is a pain in the ass to work without some goofy shit going wrong. I'd rather not go back to native Android, but maybe two Xamarin.Android and Xamarin.iOS apps are the way to go.

    Anyway, any help would be greatly appreciated! Thank you.

Sign In or Register to comment.