Forum Xamarin.Android

Where to find/How to implement the OverScroller class from android.widgets?

dlandlan BEMember

See http://developer.android.com/reference/android/widget/OverScroller.html
This class is missing from the Mono.Android API apparently.

Posts

  • CheesebaronCheesebaron DKInsider, University mod

    It is present in the Xamarin.Android API: http://androidapi.xamarin.com/?link=T:Android.Widget.OverScroller You just need a minimum target of API 9.

  • dlandlan BEMember

    How do I know what version of Mono.Android these doc's are referring to? In my installation, Mono.Android is v.2.2.0.0, and I can't find Widget.OverScroller using the Xamarin Studio Assembly Browser. Setting the minimum target to anything higher than API 9 in the project manifest has no effect, even after full restart of Xamarin Studio.

  • CheesebaronCheesebaron DKInsider, University mod

    Look at the bottom of the page in the link I posted. There is a list of Requirements, one of them says "Since".

  • dlandlan BEMember

    I saw that line... There is a difference between the version of the Mono.Android assembly as provided by Xamarin and the android API level. I assume that 'Since: API Level 9' refers to the Android API level. Question is at what point in time (i.e. Mono.Android assembly version) this class was added. Could you confirm you have the class available in your installation and tell me what version your assembly is at? Thanks.

  • CheesebaronCheesebaron DKInsider, University mod

    If I change API level to 10 it resolves OverScroller just fine...

  • dlandlan BEMember

    Ok, my bad. Quite new to Xamarin Studio and was only modifying the Android manifest, not the target framework below Build > General. Thanks!

Sign In or Register to comment.