Forum Xamarin.iOS

System.IO.FileNotFoundException: LaunchScreen.nib does not exist

ChrisLarkinChrisLarkin USUniversity ✭✭

I haven't made any changes to this file, but now all of a sudden i'm encountering this error when trying to deploy on an actual device (which was working fine previously). I disabled auto layout and size classes and that solved the problem temporarily, but now it is happening again. Does anyone know what causes this or how to solve it?

Thank You

Best Answer


  • RickStrickerRickStricker USMember ✭✭

    Since upgrading to XS 6 (5174), we are experiencing the same thing. When trying to deploy to a device, we get the same problem with one of our xib files. Simply opening the file with Interface builder and closing seems to be enough to convince xs that the file exists again. Annoying!

  • ChrisLarkinChrisLarkin USUniversity ✭✭

    Hey Rick, thanks for responding, this doesn't seem to be working for me however. Did you open the file in any specific manner, e.g. right clicking in Xamarin Studio and selecting Open in Interface Builder, or opening manually through Finder?

  • RickStrickerRickStricker USMember ✭✭
    edited June 2016

    Yes. I simply right click on the xib and open it in IB. I then turn around and close it in IB and that gets me past the error.

    Do you continue to see the xib error after opening in IB, or do you run into another after this step? We do typically run into another problem about a 29x29 icon missing, but don't want to pollute this thread with that if you're not seeing it.

  • ChrisLarkinChrisLarkin USUniversity ✭✭

    Ok that is exactly what I tried as well but it was still generating that same error. Looking at another forum posting - - it looks like the issue is related to having a deployment target of 7.0. which doesn't support size classes and thus prevents the necessary nib files from being generated. I just tried updating my deployment target to 8.0 and I'm now able to successfully build for a physical device again!

  • ChrisLarkinChrisLarkin USUniversity ✭✭

    Ok never mind. Changing the deployment target only worked temporarily as well. After running on the simulator a couple of times, I'm now generating the same error again when trying to build on an iPhone 6.

  • AnilMathpatiAnilMathpati INMember ✭✭

    I am facing the same issue.
    My deployment target is set to 8.
    Any other workaround/suggestion?

  • Hi,

    Any news with this issue?
    Also getting this when trying to deploy to iPhone 6, iPhone simulator works fine.


  • BrightLeeBrightLee KRMember ✭✭✭

    I finally found workaround.
    make sure 'Main Interface' empty in info.plist.
    Remove Bin and Obj folder.
    clean - build.

    @ShimonKlebanov @AnilMathpati

  • MCvelMCvel USMember ✭✭✭

    Hi folks,

    Does anyone knows what is causing this problem?

    deleting those folders works, but each time we make a change in the Shared project, we need to delete them before rebuild or running the app,

    thank you!

  • ChrisLarkinChrisLarkin USUniversity ✭✭

    I realized that in my case, at least, the problem was only occurring after rebuilding the project, so I got it working again by temporarily changing the deployment target - and then using clean/build instead of rebuild - and then changing the deployment target back. I haven't had any further issues since.

Sign In or Register to comment.