Forum Xamarin.Android

Xamarin Android Player isn't able to start

Every time i want to start any Android Version on any Device via Xamarin Studio, VS Studio or Xamarin Player it just shows up the loading screen but doesn't do anything.
If I start the VM through VirtualBox I get several errors on startup:


  • AlessandroCaliaroAlessandroCaliaro ITMember ✭✭✭✭✭

    Have you tried Factory Reset for the device?

  • RobertDavidsonRobertDavidson USMember ✭✭

    I am having this exact issue. I did do a factory reset however my Xamarin Android Player still is stuck on loading screen with the above error. Going to keep working on it and will let you know if I find out anything.

  • I did a Factory Reset and changed my OS from Win10 to Win8.1. Propably this switch is the reason it works for me now. one of my colleague e.g. never had a problem with Xamarin Android Player running Win8.
    With Mac I haven't had any problems until now.

  • RobertDavidsonRobertDavidson USMember ✭✭

    Once I re-installed Xamarin Android Player it worked. This time however I did not upgrade to VirtualBox 5.0.16.

  • chpochpo USMember
    edited June 2016

    i have the same problem every day and have no clue what causes it. here's what i gathered so far:

    things that CAN help:

    • start another android vm, wait for it to start, quit it and start the one you really wanted to start
    • disable windows desktop composition (e.g. in compatibility tab)
    • enable windows desktop composition...
    • delete the network host adapter:
      1. start virtualbox
      2. file->preferences->network->host-only networks: remove the adapter(s)
      3. start your vm again, it will install a new adapter
    • factory reset

    things that DO help but are even more tedious:

    • delete and reinstall the vm. for me that does not work using the gui, so you have to:
      1. close the device manager gui application
      2. open %appdata%/Roaming/XamarinAndroidPlayer/userdevices.json
      3. delete the json-subtree with the "Name" property set to the vm's name you want to delete
      4. delete the corresponding folder in %appdata%/Roaming/XamarinAndroidPlayer/VMStorageLibrary
      5. restart the device manager, the vm should be gone now
      6. install the vm again

    as my app depends on google play services the factory reset and reinstallation of the entire vm make it a really sucky process as you have to reinstall the services, reboot, (register and) login, wait for the services to update and only THEN you can try to get some work done.

    i love the idea behind xamarin but the tooling around it pretty much sucks at this state :(

  • chpochpo USMember

    i'll go ahead and update my advice list from above:

    • install a new android vm and pray it starts
    • set everything up: google play services, device settings
    • go to %appdata%/Roaming/XamarinAndroidPlayer/VMStorageLibrary
    • backup the folder named after your vm (i always zip it using "fastest" compression)
    • develop things

    when it suddenly stops working and only shows the loading indicator for ages instead of starting:

    • close every process xamarin android player related
    • go to %appdata%/Roaming/XamarinAndroidPlayer/VMStorageLibrary
    • delete the folder named after your vm
    • restore your backup you made earlier
    • try to start it
    • if it does not start: start another working vm, wait for it to load, close it, open the other one

    this process has worked for me about a thousand times (at least it feels like it) in the last few weeks.

Sign In or Register to comment.