Forum Xamarin.Android

Should I format and reinstall Windows?

Hi guys, I have these errors:

-The file "obj\Debug\android\bin\packaged_resources" does not exist.
-"aapt.exe" exited with code -1073741819
-"aapt.exe" exited with code -1073741819

This happens even when I run the default Xamarin app on a fresh project.

What happened:

  • My app worked perfectly well using Xamarin and Visual Studio 2015
  • At the weekend, I had to reinstall Windows because of an unrelated problem
  • With my new set up, the first thing I did was install VS and Xamarin, and run my app
  • This is when I first encountered these errors
  • I then read the internet and tried 1) removing version 24 Build Tools and Api 24 from my sdk, 2) checking that my resources did not contain any funny characters (even though the app was running fine before) 3) making sure that I had the latest JDK (1.8.0_92) 4) uninstalling VS and reinstalling it 4) reading the verbose output to try and work out what was wrong 5) creating a fake packaged_resources file 6) running the Xamarin default app.
  • Nothing worked

Please guys, if you have any ideas, I would be glad to know them as I was thoroughly enjoying developing my app until this happened.
At the moment, the only solution that I can think of is wiping Windows again and reinstalling it. :-(


Best Answers


  • MihaMarkicMihaMarkic SI ✭✭✭✭

    It happens that I had to try a fresh Xamarin install a week or so ago. On Windows 8.1.
    It worked out of the box without problems.
    Said that, I'd start with enabling verbose MSBuild output. Tools/Settings/somewhere.

  • StrangerweatherStrangerweather GBMember ✭✭

    Thank you for your reply. I did that but I don't understand the output. I'm posting it in case someone has a minute to look at it:


  • MihaMarkicMihaMarkic SI ✭✭✭✭

    Looks like you didn't uninstall build tools v24 after all.

    See the line:

    C:\Program Files (x86)\Android\android-sdk\build-tools**24.0.0**\aapt.exe

    Check that first.

  • StrangerweatherStrangerweather GBMember ✭✭
    edited June 2016


    Yes, I put it back because taking it away didn't help...

    Edit: tried again but no luck...

  • StrangerweatherStrangerweather GBMember ✭✭

    This is my output without build tools 24:

    Thanks for looking, I really appreciate it!

  • StrangerweatherStrangerweather GBMember ✭✭

    Thanks a lot for your help! :smile:

  • MihaMarkicMihaMarkic SI ✭✭✭✭

    You're welcome, glad you solved it.

Sign In or Register to comment.